Documentation
Tutorials
Download

Working with Slides

Every presentation in ProPresenter consists of at least one slide, even if it’s just a single media action. Each slide can tell you a lot about what is going to happen when you click on the slide, including the type of media action, whether there are any other Actions that will happen if you click on the Slide, if it is a part of a Group or has a Label, etc.

Slide Editor

The most comprehensive way to edit presentations is to use the Slide Editor. The Slide Editor provides the ability to make changes to the objects on your slides, the slides themselves, and even the Presentation as a whole.

To open the Slide Editor, click the Edit button in the toolbar, right-click on a slide and choose "Edit Slide," press Control-E on a Mac or a PC, or in the menubar select View > Editor.

Note: This section covers the Slide Editor, which is the most commonly used Editor, however there are several other Editors inside of ProPresenter that you may come across, such as the Mask Editor, the Props Editor, and the Theme Editor. All Editors are very similar, however each one has some unique characteristics that make them slightly different. Those differences will be covered in the respective sections for the feature.

Overview

  1. In the center of the Editor is the Canvas; this is where you can see and edit your currently selected slide.
  2. To the left of the Canvas is the Slide Navigator where you can select the slides you want to see in the Canvas.
  3. Below the Slide Navigator is the Object List which lists all of the objects on the currently selected Slide.
  4. Below the Canvas is the Slide Notes area where you can add notes to the slide (useful for showing presenter notes on the Stage Display).
  5. To the right of the Canvas is the Inspector; this is where you will make changes to the currently selected object, slide, or Presentation.
  6. If you want to quickly send what you are working on to the audience screen, click on the Show button at the bottom right of the Editor.

Slide Canvas

The central area of the Editor is the Canvas where you will see representations of the objects and text that is on the currently selected slide. The Canvas uses an (X, Y) coordinate system, allowing you to align objects with pixel precision.

Note: The top left of the slide is represented by the coordinates (0,0). The bottom right of the slide is represented by the coordinates (W,H) where W is the width of the slide and H is the height of the slide, both of which are set in the **Presentation Tab** of **Slide Properties**.
 In the lower left of the Editor you will see the current position of your cursor as well as the Width and Height of the currently selected object.

Moving within the Canvas

You can move around the Canvas using traditional methods (by clicking and dragging the scroll bars, for example), however there are additional shortcuts that can be used to make this faster.

If you have a mouse with a scroll wheel you can scroll vertically in the Canvas by using your scroll wheel, or hold Shift and scroll the wheel to scroll horizontally. If you are using a trackpad (including devices like the Magic Mouse) then use two fingers to scroll horizontally or vertically. You can also hold down the Command key on a Mac and click and drag on the main Canvas window to drag the view.

To zoom in or out in the Canvas you can hold down the Option key on a Mac or the Control key on a PC while you scroll, or use Pinch to Zoom if you have a trackpad. You can also use keyboard shortcuts to zoom; press Command-Plus to Zoom In, Command-Minus to Zoom Out, and Command-0 to Zoom to Fit. See the Zoom feature for additional control.

Adjusting the Canvas

The Canvas contains several tools to customize how it looks and feels; these buttons are in the lower right of the Editor.

Checkerboard Background

By default the Editor will show a grey background on the slide that you are working on. If you have set a Presentation Background Color or Slide Background Color, this color will show in the Editor on the Slide. If you would prefer to see a checkerboard texture instead of a solid color, click the Checkerboard Background button to do so. Click the button again to turn it off.

Guidelines

Guidelines are lines to which you can "snap" objects to, allowing for easily lining objects to other objects or to the center of the slide, as examples. There are three types of Guidelines: Slide Guidelines, Template Guidelines, and Alignment Guides.

Note: To create Slide and Template Guidelines, first make sure that the Rulers feature is enabled.

  • Slide Guidelines are guidelines that are unique per slide. That is, you can set up as many Slide Guidelines on a given slide as you would like, and each slide can have its own set of Slide Guidelines. To turn on Slide Guidelines, click on the Guidelines button on the lower right of the Canvas and enable Show Slide Guides, or on Mac, option-click the Guidelines button to turn it blue. To create a vertical Guideline, hover your mouse over the Ruler on the left side of the Canvas then click and drag onto the Canvas; release the mouse where you want your Guideline to be placed. Horizontal Guidelines can be created by clicking and dragging from the Ruler on the top of the Canvas. To remove a Guideline, click and drag it up (for horizontal Guidelines) or to the left (for vertical Guidelines) and release the mouse when the X icon appears. You can also right click on the Guideline and choose the option for Delete Guideline. Change the color of your Slide Guidelines by clicking the Guidelines button and clicking the color chooser next to Slide Guidelines.

  • Template Guidelines are very similar to Slide Guidelines, however instead of being unique to a specific slide, they are applied when you apply a Template to a slide, To use Template Guidelines, first go into the Template Editor and create one or more Slide Guidelines on that Template. Then, apply that Template to a slide; when you edit that slide it will contain the Guidelines that were contained within that Template. To turn on Template Guidelines, click on the Guidelines button on the lower right of the Canvas and enable Show Template Guides, or on Mac, option-click the Guidelines button to turn it blue. Change the color of your Template Guidelines by clicking the Guidelines button and clicking the color chooser next to Template Guidelines.

  • Alignment Guides will have objects snap to other objects that are in the Canvas. For example, with Alignment Guides you can snap an object to the side of another object, or even have it snap to the same spacing as other objects. There are several options that you can enable under Alignment Guides:
    • Show Relative Spacing: Enables snapping to similarly spaced objects
    • Show Relative Sizing: Enables snapping to similarly sized objects
    • Show Object Center Guides: Enables snapping to the center of other objects
    • Show Object Edge Guides: Enables snapping to the edges of other objects Change the color of your Alignment Guides by clicking the Guidelines button and clicking the color chooser next to Alignment Guides.
Grid

You can add a grid of lines to the Editor to help align your objects; click on the Grid button in the lower right of the Editor to access this feature. To toggle the grid on or off, click the checkbox next to Enable, or on Mac, Option-click on the Grid button. Click on the Color option to select which color you would like to use for your Grid. You can adjust the spacing of the Grid by setting the Spacing (the space between the major lines) and Subdivisions (minor lines that appear between the major lines). Click outside of the Grid window to close the window.

Rulers

The Editor includes a set of Rulers that will show on the top and left edges of the screen to better help you see the positioning of the objects in the Editor. You can enable and disable the Rulers by clicking on the Rulers button in the lower right of the Editor or by selecting the Editor menu and choosing Show Rulers.

Zoom

To adjust the zoom level of the Editor select the Zoom button in the lower right. You can select a predefined value or you can select Custom… to enter your own value. To have ProPresenter zoom so that you can see the entire slide, select Fit, or on Mac, Option-click on the Zoom button. Click outside of the Zoom window to close it.

Slide Navigator

To the left of the Canvas is the Slide Navigator. From here you can select which slide is currently being edited in the Canvas.

You can scroll up and down this list to see all of the slides in the currently selected Presentation. Click on a slide to select it and show it in the Canvas.

Right clicking on a slide will allow you to Copy, Paste, Delete, or Duplicate a slide. Right clicking on a Group name (if using that feature) will allow you to Rename or Change the Color of that group.

Click the "+" button at the top right of the Slide Navigator to insert a new slide after the currently selected slide. If you have your slides grouped using the Groups feature you can click the triangle next to the name of the Group to hide or show the slides in that Group.

Slide Objects

ProPresenter has a wide range of Objects that you can insert onto your slides, from simple text boxes to complex shapes and even custom shapes that you can draw yourself. There are several attributes to objects; these attributes allow for powerful control over what you show on the screen, however without a proper understanding they can cause some confusion.

An Object is any item inside of the Canvas of the Editor. Objects are very versatile and may be of many shapes and content.

All Objects have a Shape. This Shape can be one of many pre-defined shapes (such as a square, circle, or triangle) or a custom shape that you create yourself. There is no limit to an object's shape.

For each individual object you can decide if (and with what) you want to Fill the object's shape with. You can fill the shape with a solid color, a gradient, media such as a still image or a video, or one of several other options. In addition to the fill there are other properties that are linked to an object's shape (such as Stroke and Shadow) which will be covered later.

All objects are also inherently textboxes. That is, no matter the type of object you originally started out as, you can add text to it. You can activate the textbox of any object by double clicking on the object.

Note: the text of an object is NOT affected by the object's shape. Text will not stay within the bounds of an object's shape; instead the text will stay within the bounds of the object itself. To put it another way, textboxes are always rectangular, even if the object has a different Shape.

ProPresenter also has a Linking system which allows you to link Fill content as well as Text to other objects and other information within ProPresenter. Something that can be linked to is called a Token. For example, you can set the text of an object to be linked to the token of a countdown timer; if you were to do that, then whenever that object is shown the text would be replaced by the current value of that timer.

Insert an Object by clicking on the + in the upper left corner of the Canvas. From this menu you can insert the type of object that you would like:

  • Text
  • Shape
    • Rectangle
    • Rounded Rectangle
    • Elipse
    • Triangle
    • Right Triangle
    • Rhombus
    • Polygon
    • Star
    • Custom
    • Double Arrow
    • Arrow
  • Media
  • Video Input
  • Web

Some of the shapes feature controls to customize the shape. For example, creating a Star allows you to control how many points are on the star, as well as the angle of depth for each of the points.

Interacting with Objects

There are several ways you can interact with objects in the Editor. Here are a few quick tips to get more out of ProPresenter:

  • Click and drag an object to position it where you want it to be
  • Hold the Option key on Mac or Control key on Windows when you click and drag an object to copy (duplicate) that object
  • Click and drag the edge of an object (also called its "bounding box") to resize the object
  • Hold the Command key on Mac or Alt key on Windows and hover your mouse near a bounding box to turn the cursor into a Rotate cursor
  • Hold down the Shift key while dragging a bounding box to lock the aspect ratio
  • Hold down the Option key on Mac or Control key on Windows while dragging a bounding box to scale from the center of the object instead of the far corner of the object

To Align multiple objects, select multiple items, then, from the menubar, select Editor, choose Arrangement, and then Align Objects; from here you can align your items horizontally or vertically. Similarly you can select multiple items and select Distribute from the Editor menu to distribute your items horizontally, vertically, or evenly.

Object List

To the bottom left of the Canvas is the Object List which allows you to see and interact with all of the objects on the currently selected slide.

Objects that are higher on the list will appear on top of (will cover up) objects that are lower on the list. Click and drag an object in the Object List to reorder the list, allowing you to move something higher or lower in the list.

Hover your mouse over an object and click the Lock icon to lock or unlock that object. Locking an object locks it into place on the slide and you cannot edit any of its attributes until you unlock it again. Clicking on the Visible icon will hide or show the object on the Editor Canvas. Note that the object will show on your Screen when you Show the Slide.

Right click on an object to Rename, Hide/Unhide, Lock/Unlock, or Delete the object. If you have a touchpad device then you can two-finger-drag to the left of an object to delete it.

Slide Notes

The Slide Notes section of the Editor allows you to create notes on each Slide. These Notes can be used for your own reference or you can show them on the Stage Display to help the presenter remember their talking points, as an example.

To toggle the Slide Notes area click the Slide Notes button on the bottom right of the Editor. You can change the Background Color of the Slide Notes area; click the color box to select one of the pre-defined colors or click the color wheel to select your own color.

Note: The Background Color feature is a setting that is shared across all slides and all Presentations. That is to say if you change the Background Color in one Presentation then it will change it for all slides in all Presentations; you cannot customize this setting per slide or per Presentation.

You can type your text into the textbox in the center of the Slide Notes area. This textbox supports rich text formatting, meaning selected text can be bold, italicizes, different fonts, sizes, and even colors. Use the Inspector on the right of the Editor to make changes to the formatting of the text. Click on the gear icon for more features, such as paragraph settings and margins.

Tip: Sometimes you want to paste text into a textbox but you don't want to keep the formatting that was previously in the text, you want to match the formatting that was already in the textbox. To do this you can use the **Paste and Match Style** feature: press Command-Option-Shift-V on a Mac, Alt-V on a PC, or select Paste and Match Style from the Edit menu.

Slide Inspector

The right side of the Editor features the Inspector which offers you the most in-depth options for objects on your slides as well as the slide itself and even the Presentation as a whole.

Note: there are several variants of the Editor window in ProPresenter that cover unique features, for example the Slide Editor, the Template Editor, and the Props Editor (just to name a few). Each of these Editors are largely the same, however there are some features that are unique based on which Editor you are in. The following covers the Slide Editor as it is the most often used Editor; areas that are unique to each Editor will be covered in the sections that cover the overarching feature.

The Inspector is context-aware, so which options are shown at any given time is dependent on what is (or is not) selected in the Canvas. There are three groups of Tabs that the Inspector can show in the main Slide Editor: The Slide Properties Tabs, the Object Properties Tabs, and the Slide Notes Tab.

Slide Properties Tabs

If you do not have any objects selected in the Canvas, then the Slide Properties Tabs will show in the Inspector. These Tabs are the Presentation Tab (to control information for the entire Presentation), the Slide Tab (to control information about the currently selected slide), and the Build Tab (to control the Build-Ins and Build-Outs on the currently selected slide).

Presentation Tab

The Presentation Tab allows you to access information about the currently selected Presentation.

Toggle a Background color for the entire Presentation by clicking the checkbox next to Background. Click the color box to select a pre-defined color, or click the color wheel to select any color.

The Size option allows you to change the resolution of your Presentation. (Note that all slides in your Presentation share the same resolution.) Click the dropdown menu next to Size to choose a resolution for your Presentation. Tip: Generally speaking you want your slides to be the same size as your primary output, however there are cases where a different setting may be needed. If the size selected for this Presentation does not match the output size for any of your outputs then an alert will appear; click the Resize button to choose a screen to match your Presentation's resolution to. The Transition feature allows you to set, change, and remove the transition for this Presentation. The Copyright section allows you to set, change, and show the copyright information for this Presentation.

Tip: If you would like for the copyright information to show, not only does the Presentation have to have Display Copyright checked, you must also have Enable Copyright display checked in the General Tab of Preferences.

Slide Tab

To change information about an individual slide that you've selected, go to the Slide Tab in the Inspector. Click the checkbox next to Enabled to enable or disable the slide. Change the Hot Key for the slide by clicking in the textbox and typing a letter. The Label section allows you to change the Label for the slide. Toggle a Background color for the slide by clicking the checkbox next to Background. Click the color box to select a pre-defined color, or click the color wheel to select any color. You can also add, change, or remove a slide's Chord Chart. The Chord Chart feature allows you to add a PDF into the slide that will trigger to a Stage Screen if you've added a linked item to a Chord Chart on your layout.

Build Tab

The Build Tab in the Inspector allows you to set an individual transition for the Slide you have selected. There are a lot more options in this tab used once you have an Object selected.

Object Properties Tabs

When an object is selected in the Canvas the Tabs on the right change to the Object Properties Tabs. These include the Shape Tab (controls the overall shape as well as any fill content for the object), the Text Tab (controls the text that is within the object), and the Build Tab (for controlling Build-Ins and Build-Outs on the slide).

Tip: Many of the numerical input boxes in the Object Properties Tabs allow for simple math to be performed directly in the textbox! For example, if you type "100+100" into the width box and press Enter then it performs the calculation and will use/show 200 as your final width!

Tip: For some numerical input boxes you can click and drag on the label for the box and drag to the left or right to change the value in the textbox. For example, you can click on the text "Width" and drag to the left to make the object more narrow. Want even more control? Hold Shift while dragging to make bigger changes and hold Option on Mac, Alt on Windows, while dragging to make smaller changes.

Shape Tab

The Shape Tab offers a lot of great ways of controlling the object itself and what the object looks like.

Alignment and Distribution

Across the top of the Shape Tab there is a series of Alignment and Distribution buttons. If you only have one object selected in the Canvas then the first three buttons will horizontally align that object to the slide (left side of slide, center of slide, and right side of slide) and the next group of buttons will align the object vertically to the slide (top, middle, and bottom of slide). When only one object is selected the third group of buttons is not available for use.

When two or more objects are selected the Alignment buttons will align the objects to themselves (instead of the slide). For example, selecting two objects then clicking on the leftmost button (Align Left) will align the left side of both objects to the leftmost of the objects. That is, it will make their left sides line up. All of the Align buttons work this way (left, center, right, and top, middle, and bottom).

The three Distribute buttons only activate when you have three or more objects selected in the Canvas. These buttons will evenly distribute the objects amongst themselves. For example, if you have three textboxes and you want them to each be the same distance apart from left to right, you could move the textboxes into their approximate locations, select all three textboxes, then click the Distribute Horizontally button and they would each be distributed evenly along the horizontal plane.

Position, Size, Transform, and Opacity

Below the Align and Distribute buttons you can control the Position and Size of the object. Enter a number into one of the textboxes and press Enter or Tab to apply the change, or click the up and down arrows to nudge the number in the appropriate direction.

Between the Width and Height textboxes there is a lock icon. Click this icon to toggle the Lock Aspect Ratio feature. With this feature enabled the aspect ratio of the object will always stay the same.

You can also Transform the object; click the Flip Horizontal and/or Flip Vertical buttons to flip the object. Rotate the object by clicking and dragging on the rotation dial, typing an angle into the textbox and pressing Return or Tab, or by using the arrows next to the textbox.

You can change the opacity of the object by clicking and dragging on the Opacity slider, typing a number into the textbox and pressing Return or Tab, or by using the arrows next to the textbox.

Fill

In the Fill section you can choose what (if any) fill the currently selected object has. There are many options for filling the shape of an object, including a solid color, a gradient, a still image, or a video. You can also fill the shape with an active Webpage or Video Input from a camera or another input source.

One other option is to link to another object on the Slide. If you choose this option, the menu will show you all other Objects on your Slide and you can choose to link to the fill attributes of that Object. This is especially helpful if you are using a Gradient or specific color pattern and want to get the same specific formatting settings to two or more separate Objects.

Tip: Fill can also be limited by the Lines Only option in the Text Tab; if your object isn't filling correctly you might make sure that the Lines Only option in the Text Tab is unchecked.

Stroke, Shadow, and Feathering

The Stroke option allows you to add an outline to the shape of an object. You can choose if you want the stroke to be a solid line or one of several dashed lines. You can also choose the width and the color of the stroke.

The Shadow provides the option of adding a shadow to the shape of an object. Properties include Blur, Opacity, color, Angle, and Offset.

Note: The Shadow only applies to the shape property of an object and it respects both the Fill and Stroke options selected. This means that if both the Fill and the Stroke options are disabled, there will be no Shadow. To add a shadow to text go to the Text Tab of the Inspector.

The Feathering option allows you to feather (soften) the shape of an object. The higher the number, the softer the shape will be.

Visibility

ProPresenter allows the user to show or hide objects based on several variables. For example, you can have an object be hidden while a timer is counting down, but once the timer hits zero the object shows. Or you may want an object to show only if another object's textbox doesn't have any text in it.

If you would like the object to show only under certain circumstances then you can enable the Visibility feature. Select if you want the object to show when "All...," "Any...," or "None of the following conditions are met".

Below that you can add as many conditions as you would like. You can select another object on the slide and have the current object only visible if there is or isn't text inside of that other object. The other option is to select a Timer and choose to show the current object if that timer has time remaining, has expired, is running, or is not running.

Text Tab

The Text Tab of the Object Properties Inspector gives you full control over the text that is inside of an object.

Font and Paragraph

The first section offers control over the font styling of the text.
Use this area to change formatting such as the Font, Font Style, Font Size, Font Color, and other styling effects. The Copy Style and Paste Style buttons allow you to take the formatting from one slide and paste it to another slide that may have different text on it. To do this, simply click Copy Style on the slide that you wish to use the formatting for, go to the other slide and then click on Paste Style to apply that text formatting to the second slide.

There is also a gear menu which allows further formatting like those listed below.

  • Strikethrough
  • Capitalization -- here you can set your text to All Caps and other similar options like this
  • Baseline -- this allows you to have both SuperScript and Subscript characters
  • Line Height
  • Paragraph Spacing
  • Margins

Many of these formatting options for the font can also be adjusted in the Editor>Text menu in the menubar at the top of the program.

The next item is Text Scaling which allows you to dynamically scale the object based on the text in it or dynamically scale the text based on the object it’s in. Here you can choose from one of four scaling options.

  • Fit Container to Text -- this option will size the object larger or smaller to fit to the amount of the text being inputted
  • Scale Text Up to Fit Container -- this will make the text larger so it’s able to cleanly fit inside of the Object box
  • Scale Text Down to Fit Container -- this will make the text smaller so it’s able to cleanly fit inside of the Object box
  • Scale Text Up or Down to Fit Container -- this will make the text do whatever it needs to do to best fit inside of the Object box

Below the Font section you can control the paragraph formatting, such as if the text is justified to the Left, Center, Right, or Left Justified, and if the text is centered on the Top, Middle, or Bottom of the textbox.

Stroke and Shadow

If you would like to add a Stroke and/or a Shadow to the text then you can do so by checking the appropriate check box. The Stroke (an outline around the text) allows you to control the Width and the Color of the line.

The Shadow option gives you the option to set the Blur, Opacity, Color, Angle, and Offset of the shadow.

Note: The Stroke and Shadow options in the Text Tab will only affect the text. If you would like to add a stroke and/or a shadow to the shape of the object then you can do that from the Shape Tab.

Lines Only

The Lines Only option allows you to limit the object's Fill to only show in lines behind the text. This can create a masking effect on the shape behind the text, bringing focus to the text itself. You can toggle this feature by clicking the checkbox next to Lines Only. The options available to you are:

  • Height Offset: Controls the height of each line behind the text. Higher numbers mean taller lines, while smaller numbers (including negative numbers) mean shorter lines.
  • Baseline Offset: Controls where the line aligns itself behind the text. If the line is too low, increase the Baseline Offset. If the line is too high, lower this number.
List

The List feature allows you to enable bulleted and numbered lists inside of textboxes. Toggle this feature by clicking on the checkbox next to List.

Note: This feature can be applied to all lines of text in a textbox by simply having the object selected, or you can apply it to individual lines of text by selecting text inside of the textbox. You can mix and match different List formats inside of one textbox, but each line can only have one set of formatting applied to it.

  • Style: Click on the first dropdown to select which shape or numbering style you would like to use for your list.
  • Size: The Size option allows you to control how large the shape or number is.
  • Color: Click the color box to select one of several predefined colors, or click the color wheel to select a custom color.
  • Indent Bullet: Controls how indented the bullet shape/number is.
  • Indent Text: Controls how indented the text to the right of the bullet is.
Linked Text

The Linked Text feature allows you to link the textbox to other sources within ProPresenter, such as Timers, the System Clock, and other textboxes on this same slide. This can help create a more dynamic slide as well as create unique effects for some stage layouts.

For example, let's say you have a very wide output screen and want the same text to appear multiple times on the same output. Instead of copying and pasting the same text onto each slide multiple times, you could create one textbox, enter the text into that textbox, then create several textboxes that are linked to the original textbox. Joining this feature with the Templates feature of ProPresenter can create unique outputs with minimal work.

You can toggle this feature by checking the checkbox next to Linked Text.

Below are the Linked Text options that are available in the Slide Editor. Other Editors may have more or less options; see those respective sections for more information. Slide Object: This option allows you to dynamically show the text that is in one object inside of another object. With the mouse hovered over this option it will list all of the objects on the current slide (with the currently selected object grayed out as it cannot be selected). Select the object that you would like to link the text from and any text that is in that object will also be displayed in this object. There is also a Transform box that will appear below that allows you four options to transform the linked text dynamically on the Slide for more advanced integrations.

  • No Transform: This will leave your linked text with the same look as your original text only changing any formatting altered in the Text tab for the Object.
  • Remove Line Returns: Check this box if you would like to remove all of the carriage returns in the linked text.
  • One Word Per Line: This will transform the linked text to have a carriage return after every word in the text.
  • One Character Per Line: This will transform the linked text to have a carriage return after every character in the text.

Timers: Any timers that you have set up in the Timers window can be selected to be shown in the currently selected textbox.

  • Format: Under Format you can choose how the timer will be shown on the screen. There are options for hours, minutes, seconds, and milliseconds. For each of these options you have up to five choices; however depending on what you have selected in one section might disable options in another section. Here are the five options, using hours as an example:
    • h: Always show the hours but hide leading zeros
    • hh: Always show the hours and show leading zeros
    • h: If there are hours then it shows them with no leading zeros; if there are no hours then it doesn't show them
    • hh: If there are hours then it shows them with leading zeros; if there are no hours then it doesn't show them
    • - -: Hide the hours text; if there would be hours to show it adds that time to the minutes Below the formatting options there is a textbox which serves two purposes: It allows you to see a preview of what your timer will look, and it allows you to type extra text which will appear on the screen. For example, you could add the text "The service will start in " before the timer token and that text will show on the screen appropriately.
  • Color Triggers: This area allows you to dynamically change the color of the timer depending on what time is currently showing on the timer.
    • Click the + to add additional color triggers
    • Click the ˅ to Save as Default the current set of Color Triggers (allowing them to be restored in another object) or to Restore from Default, replacing the current Color Triggers with ones that had been saved before.
    • Once you have added one or more Color Triggers you can edit the time at which point they will trigger and change the color to which the timer will change to.

System Clock: The System Clock can be shown as linked text.

  • Click the ˅ next to Format to Save as Default the current set Format options (allowing them to be restored in another object) or to Restore from Default, replacing the current Format options with ones that had been saved before.
  • Date and Time: Select how you would like the Date and/or Time to be shown on the screen.
  • 24 Hour: Click the checkbox to toggle showing the time as a 12 hour or 24 hour clock.
  • Below the formatting options there is a textbox which serves two purposes:
    • It allows you to see a preview of what your clock will look, and
    • It allows you to type extra text which will appear on the screen. For example, you could add the text "The current time is " before the clock token and that text will show on the screen appropriately.

Text Ticker: Selecting the Text Ticker option will have ProPresenter show text scrolling across the screen, similar to the ticker across the bottom of a news broadcast. This feature is not currently available in ProPresenter, but will hopefully be available soon

  • Scroll Speed: Use the slider or type in a number to control how fast the text scrolls.
  • Loop: Check the checkbox to loop the text, or uncheck it to have it only show once. Change the Delay to control how long of a delay there will be between loops.
  • Delimiter: When the text reaches a carriage return it will show this text instead of the return.
  • Source: Select where you would like to pull the text from:
    • RSS Feed: Allows you to enter the address of an RSS feed to show on the screen. Can control if it will show both the Title and Description of each article inside of the RSS feed or just the Title of each article.
    • Text: Shows a textbox that you can type or copy and paste text into.
    • File: Allows you to Choose a text file on your computer to show inside of the Text Ticker. If a file is already chosen, click Open File to open the file via the computer's default text editing application, Replace to choose a different file, or the magnifying glass to show you where that file is located on the computer.

Video Countdown: Shows the time left of a video that is currently playing in the Media layer of ProPresenter (such as a Foreground or Background). Formatting options are the same as Timers above.

Build Tab

The Build Tab in the Inspector allows you to "Build In" and "Build Out" objects onto the screen. Think of this as animating objects onto and off of the screen.

You can have any and all objects on a slide build in as well as build out; however you can only have one build in and one build out per object, and the build in must be before the build out.

Builds

Build Ins and Build Outs are great ways to animate text onto and off of the screen. If you have a slide with Build Ins, Build Outs, and/or you have the Delivery mode set, when you are in the Slide View you will see empty circles across the bottom of the slide; each circle represents additional animations that you can perform on that slide.

To fire Build Ins, Build Outs, and Delivery modes, first fire the slide as normal, either by clicking on it or by using the space bar or right arrow key. After the first time you fire the slide and you are ready to show the next step in the animation sequence, fire the slide again by any of the above methods (clicking on the slide, spacebar, or right arrow key); each time you fire the slide after the first the next circle will fill in, showing your process through the animation sequence.

At the end of the animation sequence you can manually click on the next slide, or press the spacebar or right arrow key to fire the next slide. If you are in the middle of the animation sequence and want to go to the next slide without finishing the sequence, click on the next slide.

Note: Once you start the animation sequence, there is no way to go backwards in the animation sequence; if you want to start the animation sequence again you would need to clear the slide and click on that slide again to start from the beginning.

Build In and Build Out

To add a Build In or Build Out to an object, first select that object in the Canvas, then, at the top of the Build tab, select if you want the object to Build In or Build Out, then under None click on Choose… to choose which Transition you would like the Build In or Build Out to follow; see the Transition section for more information on Transitions.

Delivery

Below the Transition area is the Delivery mode; this feature of ProPresenter allows you to add additional levels of control about how the text will appear on the screen. There are two Delivery modes:

  • By Bullet: This mode will animate each line of text separated by a carriage return separately; while having bullet points in your text is not required, this is a great way of showing multiple lines of text one line at a time
  • Underline: This mode will first show all of the text in the text box with the exception of text with underlines; as you click through the slide the text that is underlined will animate onto the slide, giving a "fill in the blank" look

Note: The Delivery feature of ProPresenter can be used alongside a Build In, however it can also be used without utilizing the Build In feature. That is, if you only want to animate the Delivery of your text, leave your Build In and Build Out set to **None**, but set your Delivery mode as needed.

Build Order

The Build Order area of the Build Tab offers a visual representation of all of the Build Ins and Build Outs that you have set up on the currently selected slide. Each Build In and Build Out will have a separate row associated with it; this row will show the name of the object as well as the Transition that you have set for that build.

The first build in the list happens first in the animation sequence, and each subsequent build below it happens in that order.

To reorder builds in the animation sequence, click and drag a build to be higher or lower in the animation sequence.

Note: An object's Build Out can never happen before its Build In, thus it can never be higher in the sequence than the Build In for that object.

When you click and drag a build and hover the mouse between two other builds, you will see a blue line appear between those builds, showing you where the build will be located. If you drag, however, on top of another build, the blue line will appear on top of that other build, either on the top half of that build or on the bottom half, depending on where your mouse is. If you release the mouse when the blue line is on top of another build it will put it above or below that other build, however it will attach itself to that other build (represented by there not being a space between the two builds). This puts the lower build into a Start mode called With Build, which is covered in the Start and Delay section.

Start and Delay

At the bottom of the Build Tab is the Start and Delay section. This section controls when the selected build will start animating.

You can set the Start of the build animation to happen:

  • After Transition (only available for first build in sequence): Starts the animation (or delay timer) after the slide transition is finished
  • On Click: Waits for the user to click (or press spacebar or the right arrow key) to start the animation (or delay timer)
  • With Build: Starts the animation (or delay timer) whenever the previous build is fired; note that this ignores the delay (if any) on the previous build
  • After Build: Starts the animation (or delay timer) after the previous build is actually animated, accounting for the delay (if any) on the previous build)

You can Delay the time between when the animation is fired and when it is actually animated onto the screen. Set the Delay time by manually typing into the Delay text field, or by clicking on one of the arrow buttons to nudge the number higher or lower.

Reflow View

The Reflow Editor makes it fast and easy to make changes to text that is on your slides. This is particularly helpful when, for example, you first import a song and you need to adjust slide breaks and Groups so that the text shows correctly on your screens.

To open the Reflow Editor:

  • Click on Reflow in the Toolbar
  • Press Control-R on Mac or Option-R on PC
  • In the Menubar select View > Reflow
  • Right click on a Presentation in the Library or a Playlist and select Reflow In the Reflow Editor, the left side displays all of the text in your Presentation, and the right side shows the slides themselves. Making changes to the text on the left will immediately update the text inside of your slides on the right. Click and drag on the center divider to make one side larger or smaller.

Use the slider on the lower left to control how large the text appears in the Reflow Editor, and use the slider on the lower right to control how many columns of slides are on the right side.

While editing text, if you would like to break a slide into multiple slides you can use the Insert Slide Break feature. First, put the cursor where you would like the text to break between slides, then either click the Insert Slide Break button on the lower left or press Option-Return on Mac or Control-Enter on PC. This will create a new slide and move any text that is below the cursor to the next slide.

Tip: Pressing Option-Return on Mac or Control-Enter on PC to insert a Slide Break also works inside of the Slide Editor!

Clicking on the disclosure to the top right of each slide on the left side or right clicking on a slide thumbnail on the right side will bring up the same menu as if you right-clicked on a slide in the main Slide View Area.

Themes and Templates

Themes allow you to quickly define a set of styles for your slides. A Theme is made up of multiple Templates that can be applied to your slides. ProPresenter comes with a collection of Themes to help get you started and you can also learn to create your own to use for sermon series, events or other times where a certain style is helpful across all of your slides.

Using and Applying Themes/Templates

There are a number of ways to select the Template that you want to use, so we’ll start with updating an existing set of slides. To quickly change the appearance of a presentation, open it from the Library then click on the Style menu in the toolbar. Click the icon to open the Style menu and then click on Theme Template. When you mouse over any of the Themes you will be shown what the Templates look like within that Theme.
Click on the Template you want to use from this list. Doing so will update all of the slides in your presentation. You can also select multiple presentations and use this method to change several presentations at once.

Selecting New Theme will prompt you to name your new Theme and then opens the Template Editor. You can add as many Template slides as you wish within a Theme.

If you go to an individual Theme in the menu, there are two options at the bottom of the list of Templates as well. These options are fairly self explanatory to either Edit an existing Theme which opens the Theme Editor or Delete Theme which removes that Theme from the program.

Right clicking on a slide and opening the Theme menu offers one other option. If you build a slide you'd like to save as a Template in a Theme, you can do this by right clicking on the Slide and going to Themes, selecting the Theme you wish to put this Template under and then choosing Add Selection to Theme

Theme Editor

If you need to Edit a Theme that has already been created or wish to create a new Theme, the slides that will be used as Templates are found in the Theme Editor.

Note: The Theme Editor is very similar to the Slide Editor. This section will only cover parts of the Editor that are unique to the Theme Editor. For general information about the Editor as well as items that are not covered here, please see the Slide Editor section.

Theme Editor Interface

There is no Slide Notes feature in the Theme Editor.

Template Slide Tab

When no objects are selected on the Template Slide in the Editor, the Inspector on the right side of the Editor window will show a single Template Slide tab.

This is where you set the basic formatting of your Template slides. This includes three editable options...

  • Name -- Here, you can name your Template Slide. This is the Label that will show in the Theme menu alongside the thumbnail of what the slide will look like once applied.
  • Size -- This allows you to set the size of the Template Slide itself -- typically, this would match the resolution of the screen the slides will be displayed on.
  • Background -- Here, you can toggle on whether the Template Slide has a colored background on it or not. Enabling this option allows you to set a color using the basic or advanced Color Palette.
Object Inspector

There are no differences in the Object Inspector when an object is selected in the Editor between the main Slide Editor and the Template Editor.

Groups and Arrangements

Groups and Arrangements make it easy for you to create multiple versions of a single Presentation without having to save several files in your Library. This feature allows you to define slides as part of a stanza (Group) and then arrange them in whatever order you need.

By default, there is a set of Groups already created inside of the program that can be used and/or modified. You can view these Groups in the Label tab of ProPresenter Preferences.

To get started, right-click on a slide and select a Group Name. If you have 8 slides and start on the first slide, all 8 slides will be grouped into the selected group. If you start on slide five, the first four slides will remain with the generic “No Group Name” and the last four slides will be in your selected Group, for example “Verse 1”. This second scenario is shown in the image below. You can right-click on any slide to start a new Group for the slides between that slide and the next Group. If slide three is selected above and named “Chorus,” only slides 3 and 4 will be affected. Slides 1 and 2 still have “No Group Name”. Groups can be renamed by repeating the naming process and selecting a new name. Groups can also be split into additional groups by right-clicking on one of the slides and selecting a new Group. In the image below, the last four slides have been split up into three groups, with slide five being the only one that is still part of Verse 1. You can also turn on the Arrangement feature by clicking on the button in the top right of the Presentation Header that looks like this. This will show each Group represented by its own button (“Token”). To create a new Arrangement for your presentation, open the Arrangements toolbar and click on the dropdown menu on the left and select New Arrangement.... You will be prompted to name this new Arrangement.

Once you have created your new Arrangement you will need to drag the Groups into the order that you want to be shown in that new Arrangement. Click on the Tokens in the top row and drag them to the second row to organize your Arrangement. If you repeat a Group in your Arrangement, any edits made to one of those instances will apply to the others. For example, if you have Chorus in your Arrangement five times and add a background to the first slide of the Chorus, it will be added to the other instances of Chorus. This also applies to any changes made to the text on a slide. These changes are also reflected in other Arrangements that use the same Group. The properties of an Arrangement are not unique to that specific Arrangement.

Due to how Arrangements are stored within the song file, you can actually have the same presentation in your playlist multiple times with a different active Arrangement selected for each instance of the presentation. To change the Arrangement, right-click on the Presentation in the Playlist and select the Arrangement from the Arrangement> menu. You’ll see the Arrangement name in [brackets] at the top of the presentation when you open as you can see in the image above, as well as, in the Library and Playlist. The selected Arrangement is stored as part of the Playlist data, so exporting the Playlist will maintain the proper Arrangement when you open it on another computer.

Slide Actions

Slide Actions are one of the most powerful and versatile features of ProPresenter.

An Action is an event that happens inside of ProPresenter. This can be showing ("firing") a Background to the audience screen, or the changing of a Stage Display layout, or sending a DMX signal out of the computer.

ProPresenter lets you add Actions to slides so that when you click on the slide, the Actions attached to that slide are also triggered. These are called Slide Actions.

Let's say that you want a background to fire when you click on a specific slide, or you want a timer to start when a slide is clicked, or you want a Message to show on the screen when you get to a specific part of a Presentation. All of these are perfect examples of Slide Actions.

In fact you can have multiple Slide Actions on one slide. So you might have a single slide that fires a Background, changes the Stage Display Layout, changes the Audience Look, and sends a Midi signal to turn on the stage lights. That's a lot happening with one mouse click!

This section describes all available Slide Actions inside of ProPresenter, as well as how to add them to a slide and how to edit them.

Slide Action Basics

Slide Actions are represented by icons that appear on or near a slide's thumbnail so that you can quickly identify what Slide Actions are attached to which slides. In the main slide area of ProPresenter, if you are using Grid View or Easy View, the Slide Action icons appear on the top left of the slide's thumbnails; in Table View the icons appear to the right of the text.

Note: For some Slide Action types there can only be one of that type per slide, but for other types there can be multiple of the same Slide Action on a given slide.

How to add Actions to slides will be covered in each specific section below. To edit (change the properties) of a Slide Action, right-click on that slide and:

  • If there is only one editable Slide Action on that slide, choose Edit Action: [Name of Action].
  • If there are multiple editable Slide Actions on that slide, hover your mouse over Edit Action and choose the Action from the submenu that you would like to edit.

To remove a Slide Action from a Slide, right-click on that slide and:

  • If there is only one Slide Action on that slide, choose Remove Action: [Name of Action].
  • If there are multiple Slide Actions on that slide, hover your mouse over Remove Action and choose the Action from the submenu that you would like to remove.

To remove all Slide Actions from a slide, right-click on that slide, hover over Remove Action, and choose Remove All.

Action Palette

Oftentimes the easiest way to add an Action to a slide is via the Action Palette. This is one window that gives you access to many (but not all) Actions you can drag onto slides for easily adding Actions to Slides. To open the Action Palette:

  • Right-click on a slide, hover over Add Action, and click on Action Palette…
  • Press Control-Shift-C on Mac or Alt-A on PC
  • In the menubar select View > Action Palette

To add an Action to a slide from the Action Palette, simply click and drag the Action from the Palette onto a slide.

Clear Actions

Add a Clear Action to a slide to clear other areas of ProPresenter when you click on that slide. These Actions can be added to slides by right-clicking on a slide and hovering over Add Action > Add Clear Action; Actions marked with an * can also be added via the Action Palette.

Clear Actions that are available:

  • Clear All
  • Clear Audio
  • Clear Background (Clear Bkg)
  • Clear Video Input (Clear Input)
  • Clear Prop
  • Clear Message
  • Clear Slide
  • Clear to Logo

You can have multiple Clear Actions on one slide, however you can only have one of each type on a given slide.

Media Actions

ProPresenter can fire media files such as a still image, a video, and audio from a Slide Action.

Graphic Action

Adding a graphic (that is, a still image or a video) to a slide will fire that slide to the Foreground or Background layer of ProPresenter, depending on how that Action is set up:

  • Foreground Graphic
  • Background Graphic

You can add a graphic to a slide one of several ways:

  • Right click on a slide and choose Add Media Action…, then browse to the graphic file on your computer
  • Drag the Graphic icon from the Action Palette to the slide, then browse to the graphic file on your computer
  • Drag a graphic from the Video/Image Bin onto the slide
  • Drag a graphic from the computer file manager (Finder on Mac, Windows Explorer on Windows) onto the slide

Once the Action has been added to the slide, if you need to change the behavior between Foreground and Background you can right-click on the slide and under Media Action Behavior choose which behavior you would like.

You can only have one graphic Action on a slide at a time.

Audio Action

To fire audio on a slide you can add an Audio Action to that slide. Audio tracks have two types:

  • Audio Track
  • Sound Effect

See the Audio Bin section for more information on the two Audio types.

You can add audio to a slide one of several ways:

  • Right click on a slide and choose Add Media Action…, then browse to the audio file on your computer
  • Drag the Audio icon from the Action Palette to the slide, then browse to the audio file on your computer
  • Drag audio from the Audio Bin onto the slide
  • Drag audio from your operating system onto the slide

You can only have one Audio Track on any given slide, however you can have multiple Sound Effects on slides.

Note: Once an audio file has been added to a slide as an Action, there is no way to change the behavior between Audio Track and Sound Effect; you would need to add the audio to the Audio Bin, change the behavior, then drag the audio to the slide.

Video Input Action

Add the Video input Action onto a slide to automatically turn on or change the Video Input layer of ProPresenter when that slide is clicked.

Add the Video Input Action to a slide by opening the Action Palette and dragging the Video Input Action onto a slide; doing so will give you the option to choose which Video Input you would like to assign to that slide.

Interactive Actions

This section covers the rest of the features of ProPresenter that can be controlled by Slide Actions.

Stage Layout Action

Use the Stage Layout Action to change Stage Layouts on the fly. Add a Stage Display Action to a slide by right-clicking and going to Add Action > Stage Display Layout or opening the Action Palette and dragging the Stage Display Action onto a slide; doing so will give you the option to choose which Stage Display Layout you would like to assign to that slide.

You can also change your Slide Destination here which allows you to choose if you'd like to send the slide to only your Stage screen or to both the Stage and Audience screens. Selecting Stage will toggle on the Stage Only mode for your slides. You would need to set a second Action and set it to Stage + Audience to toggle this setting back off when you wish for your slides to show on the Audience screens again.

You can set both the Layout and Slide Destination to change with the same Action.

Timer Action

Adding Timer Actions to slides offers additional controls for starting, stopping, and restarting your Timers.

There are two ways to add a Timer Action to a slide:

  • Right-click on the slide and choose Add Action > Timer > [Timer]
  • Open the Action Palette and drag the Timer Action onto a slide

When adding or editing a Timer Action you will have the ability to configure the Action in one of several ways:

  • Select which Timer this Action is controlling
  • Select if this Action will Start, Stop, or Reset the given Timer
  • Toggle if you want to Set the Configuration (such as Type, Duration, and Overrun) of the Timer using custom parameters to this Action, or if you want the Timer to keep the configuration that it already had

You can have multiple Timer Actions on one slide.

Prop Action

You can quickly add Prop Actions to slides to show specific Prop(s) when you click on a specific slide.

Add Prop Actions to slides by opening the Action Palette and dragging the Prop Action onto a slide. When adding or editing a Prop Action you will be able to select which Prop you want to fire when that slide is clicked.

You can have multiple Prop Actions on one slide.

Audience Look Action

Use Audience Look Actions on slides to quickly change which Look you are using to show content to the audience screens.

Add Audience Look Actions to slides by either:

  • Opening the Action Palette and dragging the Audience Look Action onto a slide or
  • Right clicking on a slide and selecting Add Action > Add Audience Look Action and choosing which Audience Look you want to use

When adding or editing an Audience Look Action you will be able to select which Look you want to use when that slide is clicked. This will change the Live Look that is used until a new Look is selected either via an Action or through the Looks menu.

You can only have one Audience Look Action per slide.

Message Action

Add Message Actions to slides to show specific Message(s) when you click on a specific slide. Add Message Actions to slides by opening the Action Palette and dragging the Message Action onto a slide.

When adding or editing a Message Action you will be able to select which Message you want to fire when that slide is clicked, as well as be able to edit any variables that you have set up inside of that Message.

You can have multiple Message Actions on one slide.

Communication Action

Using Communication Actions on slides helps to quickly send Communication signals when a slide is clicked.

Add Communication Actions to slides by either:

  • Opening the Action Palette and dragging the Communication Action onto a slide or
  • Right clicking on a slide and selecting Add Action > Add Communication Action

When adding or editing a Communication Action you will be able to select which device you are sending a signal to and what command you want that signal to have.
You can have multiple Communication Actions on one slide.