Documentation
Tutorials
Download

The Interface

ProPresenter's user interface (the primary window in which you interact with the program) has evolved over the years to where it is now. The goal is to give you powerful controls while also being streamlined and easy to use.

This page outlines the main features of the primary window inside of ProPresenter with links for more information about features discussed here. Below we will dive into each section, but just in way of a quick overview:

  1. The main area is the View Mode, where you see, interact with, and build your Slides
  2. Across the top you have the Toolbar which quickly gets you to different areas of ProPresenter
  3. Along the left is where you see all of the Presentations in your Libraries as well as where you will build your Playlists
  4. The bottom features your Media Bin (which can be hidden), giving you quick access to your Image/Video Media files
  5. The top right is all about what is going out of ProPresenter; see the Preview, click on a Clear button or see the progress of the currently playing video in this area
  6. The bottom right features the Audio Bin, where you can play back audio files with an easy click

Let's dive deeper into each of these unique sections.

View Mode

The area with the most real estate in ProPresenter is the View Mode. This area covers the center area of ProPresenter and has multiple uses; you can switch between these functions using the buttons on the left center of the Toolbar.

Show View

During a live performance you will likely be spending most of your time in the Show view of the Multi-View. This is the main ProPresenter area where you can control and trigger your slides to your screens and literally, run the Show.

The Presentation Header

  1. Slide Show Mode -- The Slide Show button allows you to execute a trigger event that runs every slide in a presentation for a certain amount of time. As this setting is handled in the presentation data versus the slide/cue data, it does not add a Go to Next Timer on every slide, it just executes the trigger event at the end of each timer and it applies to all slides. In this manner, if you already have a Go To Next Timer on a slide, the slide's Go to Next Timer would override the time set in the Slide Show button. In addition, the final slide will always loop back to the first slide in the presentation. When you enable this setting, it will show blue and list the amount of time that the slides will run for. The default values are 5, 10, 15, 20, or you can choose to set a Custom amount of time.

  2. Operator Notes -- Clicking this button allows you to add a small line to enter Notes into the program for a Presentation. Notes that are added here are shown at the top of the Presentation in a dark gray bar just below the Title. Operator Notes are useful if you need to include a general reminder about something related to the Presentation for the person running ProPresenter.

  3. Groups/Arrangements -- This button allows you to toggle open/closed the Arrangement window. This is where you can setup your Arrangements and set what Arrangement will be used by the Presentation. For more information on creating and Arrangements and setting up Groups in your Presentation, go to the Groups/Arrangements section.

  4. Timeline -- This allows you to open the Timeline for the Presentation. The Timeline gives the option to create presentations with custom timings between slides or to record the slides to match a song with or without an audio track. More information on this feature can be found in the Timeline section.

  5. Destination Target -- The Destination Target button lets you set whether the Presentation you have selected will go to the Presentation or Announcements Layer. Your choice here would be dependent on how you have your screens and your Audience Look setup. More information on setting up your Audience Looks and the differences in the Presentation and Announcement Layers can be found here.

  6. Presentation Transition -- The Presentation Transition is where you can set a transition to be used for all of the slides in a Presentation. This would override the Global transition set in the bottom left of the Show View Area and would be overridden by a transition added locally onto a single Slide.

Viewing/Triggering Slides

There are three different ways you can view your slides in this area: Grid View, Table View, and Easy View. You can change which view you're using in the bottom right corner of the Show View by clicking on one of three buttons. The fourth button is the Settings for that particular view. No matter what view you're in, the Slider on the far bottom right controls the size of the Thumbnails in the Show View area.

Grid View

Grid View is the default view for ProPresenter. There are a number of visual icons that appear on each slide thumbnail to help you know what will be triggered on each slide. Hot Keys and other slide action icons are shown in the upper left corner of the Slide thumbnail and a transition icon appears in the bottom right of the thumbnail if a local transition is set on the Slide. The active slide is outlined in orange.

The Settings at the bottom right include two options: Slides by Group and Background Color. With Slides by Group enabled, Slides are broken down into their individual groups and shown with more separation. If you are using an Arrangement, each instance of a group in the Arrangement will be separated. This view can be helpful if you don’t have a pre-set order for the song and want to be able to quickly find each section of the song. The Background Color allows you to change the slide background color on your thumbnail. This does not affect the physical output of the slide and only applies to the thumbnail for better viewing of the slides.

Easy View

Easy View is a new view option in ProPresenter that allows you to set what your thumbnails look like without changing the output of the Slides themselves. This View is similar to Grid View, but no media actions are shown in the Slide thumbnails and the text is formatted based on your Settings.

In the Settings tab, you can set the following items for how the text on your Thumbnails will look.

  • Slides By Group: As in Grid View, here, slides are broken down into their individual groups and shown with more separation.
  • Cue Background Color: Choose a color from the color palette to change the thumbnail's background color.
  • Font Formatting: Change your font type, style, size and color. This allows you to setup your text to better read what is on the slide. This is especially helpful if you have smaller lower thirds on your slide that are harder to see on the thumbnail.
  • Alignment: Here, you can set the horizontal and/or vertical alignment of the slide text in your thumbnail.
  • Truncate: Truncate allows you to pick what portion of text would not be shown in the thumbnail if the text is too large to fit inside. You can cut either from the beginning, middle or end of the Slide text.
Table View

Table View is similar to Grid View and Easy View, but you also get a plain text view of the slide text in addition to the thumbnail. This view uses the same icons to indicate Actions and Transitions. This view also includes any Slide Notes that you have added to your presentation. The active slide is orange, and more obvious than in the Grid/Easy View.

The Settings here are similar to Easy View, but affect the plain text view of your Slide's text on the right side of the view. You can also set a background color for the Table itself alongside setting up a separate background color for the Slide thumbnails.

Miscellaneous Options

There are a few other options that can affect how you view your slides and how they're triggered here.

Show Triggered Presentation/Announcement

The options for Show Triggered Presentation and Show Triggered Announcement can help you quickly load the currently showing items on both the Presentation and Announcement Layer. These items are found in the Presentation menu.

Show Triggered Presentation will load the currently showing Presentation from the Presentation Layer into the Show View. You can also use the keyboard shortcut of Command-L on Mac or Control-L on PC to load this item.

Show Triggered Announcement will load the currently showing Presentation from the Announcement Layer into the Show View. You can also use the keyboard shortcut of Shift-Command-L on Mac or Shift-Control-L on PC to load this item.

Continuous Playlist

In previous versions of ProPresenter, this was known as "Contiguous" view. This allows all items in a Playlist to be loaded at one time into the Show View so you can scroll through the entire Playlist at once. You can toggle this on/off by going to View>Continuous Playlist in the menubar.

Global Transition Control

Across the bottom of the Show View, there are three transition buttons which determines the Master Slide Transition; think of this as a "default transition" that all slides will use unless there is reason to use a different transition. You can either set a Cut, Dissolve or a more Advanced Transition here. For more information on Transitions, access the Transitions section here.

Edit View

Clicking on the Edit view button brings up ProPresenter's Editor; read more about the Editor in the Editor section of this user guide.

Reflow View

The Reflow view makes it quick and easy to edit the text of your Presentations; click on the Reflow view button to open the Reflow Editor. Learn more about the Reflow view in the Reflow section of this user guide.

Bible View

Many of ProPresenter's users want to quickly show Bible verses to their audience. The Bible view quickly allows you to show one or more Bible verse on the screen at a given time. Read more about the Bible view by visiting the Bible section of this User Guide.

Other Views

There are several other view modes that you may find ProPresenter using (such as while using the Stage Editor or the Props Editor); in all of these cases, the "More" button in the Toolbar will be highlighted. To return to one of the main views simply click on the associated view button and it will close out of that particular view.

Toolbar

The Toolbar lives across the top of the ProPresenter user interface and lets you quickly access many of the features of ProPresenter. Starting with the top left:

  • Search: Brings up the Search window
  • Text: Allows you to apply a new text formatting using the options in the menu to the currently selected slide(s) or Presentation(s).
  • Theme: Allows you to quickly apply a new Template to the currently selected slide(s) or Presentation(s).

Multi-View Buttons:

  • Show: Shows the Show view
  • Edit: Shows the Edit view
  • Reflow: Shows the Reflow view
  • Bible: Shows the Bible view
  • More: Opens a menu with access to all Editors other than the Slide Editor which is opened through the Edit button

Feature Buttons:

  • Timers: Toggles the Timers Pane
  • Messages: Toggles the Messages Pane
  • Props: Toggles the Props Pane
  • Stage: Toggles the Stage Control Pane
  • Store: Toggles the Media Store
  • Media: Toggles the Media Bin

Library and Playlists

The leftmost section of ProPresenter's user interface allows you to interact with the Presentations that are in your Libraries and Playlists.

A Presentation is most simply a group of slides. That is, any time you want to have a number of slides that are grouped together for easy access, you will create a Presentation and add those slides to that Presentation. Common examples of Presentations are songs, speaker notes, or announcements.

A Library is a large database of Presentations, typically containing all of the Presentations you have created and want to use again. For example, you may have a Library that contains all of your available songs, or maybe have different Libraries for different types of services that will be run on that presentation computer. Libraries will always sort their Presentations alphabetically.

A Playlist is a small group of Presentations, typically representing a specific event or service. For example, if you have an event or service coming up, you would create a Playlist, then add Presentations into that Playlist and organize them in the order that they will be used in your event or service.

Note: Presentations can be in multiple Libraries, but each Presentation is then seen as a different file. Think of a Presentation as having a property for which Library it is located in. That Presentation can also be added to one or more Playlists (or even to a single Playlist more than once), however the Playlist is simply referencing the original Presentation. So it doesn't matter where you make a change to a Presentation (its Library or a Playlist), that change will be made to all Playlists that reference that Presentation. On the upper portion of the left side of ProPresenter you can see and organize your Libraries and Playlists.

Click the + button to:

  • Add a New Library
  • Add a New Presentation
  • Add a New Playlist
  • Add a New Playlist Folder
  • Add a Planning Center Service…

Click on the ^ button to hide the Library and Playlist section, allowing the operator to focus solely on the contents of the currently selected Playlist or Library. While in this mode, the name of the current Playlist or Library will be shown across the top; click this name to show a list of all Playlists and Libraries, then click on a new Playlist or Library to show the contents of that item. Click the v button to reveal the Library and Playlist section again.

Libraries

Click and drag a Library to re-order your Libraries. To rename a Library, right-click on the Library and choose Rename. To delete a Library, right click on the Library and choose Delete, or select the Library and press the Delete or Backspace key.

Playlists

Click and drag a Playlist to re-order the Playlists. To rename a Playlist, right-click on the Playlist and choose Rename, or select a Playlist, wait a moment, and click the name again. To delete a Playlist, right-click on the Playlist and choose Delete, or select the Playlist and press the Delete or Backspace key. You can export a Playlist by right-clicking on a Playlist and choosing Export, or select the Playlist and in the menubar select File > Export > Playlist….

Media Bin

The Media Bin, situated at the bottom of the main ProPresenter window, is a great way to organize and fire still images and videos.

To show or hide the Media Bin:

  • Click the Media button on the top right of the main ProPresenter window,
  • Select from the menubar View > Media Bin
  • Press Control-V on a Mac or Control-Shift-V on a PC.

Note: For the purposes of this section, "media" refers to still images and videos; audio cannot be added to the Media Bin as it would need to be organized via the Audio Bin.

The Media Bin is divided into two sections: the Outline View which lists your Media Playlists and Folders on the left and the Detail View listing the contents of those Playlists on the right. Click and drag the divider between the sections to resize the two sections. Click and drag the divider across the top of the Media Bin to make it larger or smaller.

Media Playlists

The left side of the Media Bin allows you to have multiple Media Playlists to help organize your media. Add Smart Playlists to have ProPresenter automatically reflect the contents of a folder on your computer, and add Playlist Folders to help organize your Media Playlists.

Media Playlists are Playlists that can contain both Foreground and Background media. Think of a Media Playlist as a container for organizing and separating your media files. For example, you might have a Media Playlist for slow motion backgrounds and one for fast motion backgrounds; one for media that has blue as its primary color and one that has media with red as its primary color. You can add, remove, and sort as many media files as needed into Media Playlists.

A Smart Playlist is a special type of Media Playlist that looks at a folder on your computer and automatically adds and removes media based on the folder on your computer. You cannot manually add or remove Smart Playlist media directly inside of ProPresenter, instead that would have to be done via the operating system on the computer; open the operating system and add or remove your media from that folder and ProPresenter will instantly update to reflect the change.

Note: Smart Playlists ARE "recursive," meaning it will not only search the folder you point it at, but also any sub-folders within that folder.

Playlist Folders are for organizing Media Playlists and Smart Playlists. That is, Folders cannot contain media themselves, instead they contain Playlists which contain media.

There are two special Media Playlists that are always visible:

  • Downloads contains media that was downloaded from the Renewed Vision Media Store
  • Video Input shows the video inputs that you set up in the Video Input tab of Preferences

Click and drag a Playlist or Folder to organize the Playlist area. Click the + button to:

  • Create a New Playlist
  • Create a New Smart Playlist
  • Create a New Playlist Folder

To rename a Playlist, select that Playlist, wait a few seconds, then click on the name again.

Media Cues

The main area of the Media Bin shows the contents of the currently selected Media Playlist. That is, it shows all of the media that is contained within the Playlist that you most recently clicked on.

This area has many uses. It helps organize and prepare your media. You can, with a quick look, see many of the properties of a given piece of media. You can fire media (show it to the audience screen) simply by clicking on it. You can also quickly drag media from the Media Bin directly on top of a slide in the Slide View to attach that media as an Action to that slide.

Add media by dragging the media from your computer's operating system onto this section, or by clicking the + in the lower left. Click and drag media to manually organize the media, or right click on a piece of media, hover over Clean Up By, and choose one of the options to sort the media by that category.

On the bottom left, select one of the transition options for controlling what the default media transition effect/time will be. See the Transition section for more information.

Note: The default media transition can be overruled by a transition being added to a specific media action.

Across the bottom of the Media Bin click on the Filter textbox to do a name search of all of the media in the currently selected Playlist. Click the X button to clear the search.

On the bottom right of the Media Bin you can control how the media thumbnails look in the Media Bin. Drag the slider to make the thumbnails larger or smaller. There are two views for the Media Bin:

  • Grid View: The media thumbnails are shown in a grid; this shows more thumbnails but shows limited information about the media itself.
  • Table View: The media thumbnails are shown in a table; this limits the number of visible thumbnails, however it provides more information about the media itself, such as the Path (where the media is located on the computer), its Duration, its Format, and Producer (if downloaded from the Media Store). Click on a column header to quickly sort by that column. To toggle a column in Table View, right click on the header and click the column you wish to toggle.

Right-clicking on a media thumbnail gives you a wide range of options:

  • Layer: Control which layer (Foreground or Background) the media will play back in
  • Scaling: Control how the media will be scaled (Scale to Fill, Scale to Fit, or Stretch to Fit)
  • Playback: Control if the video will Stop, Loop, or Soft Loop at the end of the video
  • Next Cue: Control which media file (if any) plays at the end of the video
    • This setting is only applicable in the Media Bin Playlist and will not transfer if the Media Cue is added as an Action on a Slide or into a Library Playlist
  • Inspector…: Opens the Media Inspector. You can see more information on this here.
  • Transitions…: Allows you to set a unique Transition for this media file
  • Show in Finder or Reveal in File Explorer: Shows where the media file is stored on the computer
  • Clean Up By: Sorts the current Playlist by the option selected
  • Cut, Copy, Paste, Delete: These are the standard use commands in working with files

Preview Window

The Preview area of ProPresenter, located on the top right of the main ProPresenter window, gives you quick access to not only see the output of ProPresenter, but also quickly turn on and off the Audience and Stage Screens, and clear Layers of content.

Audience and Stage Preview

There is a large Preview window which lets you see a preview of one of your Screens. Click the down arrow below the Preview window to select which Screen (Audience or Stage) you would like to Preview.

Tip: See the Screen Configuration section for more information on how to set up your Screens.

Across the top of the Preview window there are two icons will tell you if your Audience and/or Stage Screens are on or not. If the light is green then those Screens are on, if the light is red then those screens are off. You can click on these buttons to toggle the Audience and/or Stage Screens off/on. This applies only to the system outputs attached to the machine.

Clear Buttons

To the right of the Preview window are a series of icons, each one representing a Layer. If content is filling a given Layer, then that Layer's button will turn red.

Click on any of the buttons to Clear that Layer. Click the Clear All button to clear all of the Layers at once.

You can also clear Layers by going to the Action menu in the Menubar, or by pressing the corresponding keyboard shortcut:

  • F1: Clear All
  • F2: Clear Slide
  • F3: Clear Background
  • F4: Clear Props
  • F5: Clear Audio
  • F6: Clear Logo
  • F7: Clear Announcements

Clear to Logo

If you have a logo set in the General tab of ProPresenter Preferences, an option for Clear to Logo will appear in the bottom right corner of the Preview window. Clicking on this button will immediately send your selected logo to the Media layer of your Audience screens. If you do not have a logo set in Preferences, this option will not appear in the window.

Transport Controls

Below the Preview window an area where you can see and control the progress of currently playing media; these controls are often called Transport Controls.

Across the top of the Transport Controls are three icons; these icons control which media the Transport Controls are showing:

  • Foreground/Background Media
  • Announcement Media
  • Audio Files

Below these icons is a scrub bar. If you are playing a video in the currently selected layer (or audio file if the audio layer is selected) then you will see the progress of the video in the scrub bar; click and drag the scrub bar to control the timing of the video.

Below the scrub bar are four buttons:

  • Rewind 15 seconds
  • Pause/Play
  • Fast Forward 15 seconds
  • Jump to...

The *Jump to... button is customizable; right click on it and choose between:

  • -0 (jump to the end of the video)
  • -10 (jump to the end of the video with 10 seconds left)
  • -30 (jump to the end of the video with 30 seconds left)
  • -60 (jump to the end of the video with 60 seconds left)
  • -90 (jump to the end of the video with 90 seconds left)

Audio Bin

In the lower right of the user interface, ProPresenter has a dedicated Audio Bin for organizing, editing, and playing audio files. Create Playlists to organize your audio, use the Media Inspector to edit and customize your audio, and use the playback controls from within the bin to control the audio as it plays.

Audio Types

Inside of ProPresenter, audio files must be categorized as one of two types:

  • Audio Track: Generally used for longer audio files such as songs or spoken word, Audio Tracks are limited to only playing one at a time inside of ProPresenter and can be controlled via the playback controls at the top of the Audio Bin.
  • Sound Effect: Generally used for shorter audio files such as sound effects in a dramatic program, Sound Effects can have several playing at once and have no direct conrol options.

Tip: Audio files less than 10 seconds are automatically categorized as Sound Effects, while longer audio files are categorized as Audio Tracks. This can always be changed for any file by right-clicking on the file and selecing "Set as...".

Outline View

Across the top of the Audio Bin is the Outline View where you can create and organize Playlists of audio files. An Audio Playlist can contain audio files. Audio Playlist Folders do not contain audio files themselves, instead they contain Audio Playlists. That is, you can use Playlist Folders to organize your Playlists, and Playlists to organize your audio files.

Create new Playlists and Playlist Folders by clicking the + button across the top of the Playlist view. Click and drag Playlists and Playlist Folders to rearrange them. Select a Playlist or Playlist Folder then click the name again to rename the item. Right click or select and press the Delete key to delete items.

You can collapse the Playlist view by clicking the ^ button; this allows the operator to focus on the contents of just one Playlist. In this mode, click the name of the Playlist to select a different Playlist, and click the v to open up the full view again.

Audio View

Once you select a Playlist you can then see the audio files contained in that Playlist at the bottom of the Audio Bin. Clicking on any audio file will play it immediately.

You can add audio files to a Playlist by clicking the + between the Playlist View and Audio View, or by dragging them from your operating system to this area. The Filter bar will allow you to search the currently selected Playlist.

Use the slider at the bottom of the Audio bin to control how long the transition is between audio files (including when you start and clear audio files) and you can click on the Shuffle button to shuffle the Audio Playlist that you have selected.

Right click on an audio file to access additional options:

  • Reveal in [Finder/System]: Shows where the audio file is currently stored on the computer
  • Playback Behavior (Audio Track only): Controls what happens at the end of an Audio Track:
    • Stop
    • Loop
    • Loop for Play Count...
    • Loop for Time...
  • Next Cue (Audio Track only): Controls what audio files plays when this one finishes
    • None: Nothing happens
    • Next: The next file in the Playlist (or, if Shuffle is turned on, a random file in the Playlist) is played
  • Set as [Sound Effect type/Audio Track type]: Changes the audio track type
  • Inspector: Opens the Audio Inspector. You can see more information on this here.
  • Rename: Renames the file
  • Delete: Removes the audio track from the Playlist