Documentation
Tutorials
Download

Working with Files

Importing

There are various types of files that can be imported into ProPresenter and options as to how those files will come into the software.

To access the Import options inside of the program, go to File>Import in the menubar and select one of the options from the submenu. You can also drag files from your computer folders into the Library or Media Bins in the program to start this process.

Import File

This option is used to import many different types of files including text files (.txt or .rtf), Word files (.doc or .docx), ProPresenter Presentation files (.pro5, .pro6, or .pro) and ProPresenter Bundle/Playlist files (.pro6plx, .pro6x, .proBundle, .proPlaylist).

If you select a ProPresenter file to import and you have multiple Libraries, you will be prompted what Library you wish to put this presentation into. If you only have a single Library, the file will begin importing automatically.

If you select a text or Word file to import, you will be shown options for importing like those below.

Slides delimited by allows you to specific a number of lines or paragraphs per slide, or to use a custom slide break marker in the source file. Regardless of which delimiter you use, the number placed in the Delimiters per slide box determines when new slides are generated. If you have selected “Line Break” and enter “2,” you will end up with two lines on each slide, with respect for stanza breaks. Same with paragraphs. If you have used a customer delimiter such as “//” or “*” in your file, just type that into the “Slides delimited by” field.

The middle section allows you to update the Size and Template that will be used for the file you’re importing.

You can also set the Destination where the file will go setting both a Library (provided you have multiple Libraries) and Playlist. You can also choose for the presentation to go to a New Playlist or No Playlist. If you choose New Playlist you’ll be prompted to enter a name for that Playlist.

The Edit button in the lower-left corner opens the presentation in Reflow View. You can learn more about Reflow View here.

Import Text from Clipboard

This option uses the same import options as Import File, but allows you to copy text from a website or a file such as a PDF or other file type not supported by ProPresenter and import it into a Library.

Import PowerPoint

If you have PowerPoint installed on your computer, you can convert PowerPoint files into formats ProPresenter can use. Choosing this option will open a computer browse window so you can find the PowerPoint file on your machine. Once you have located the PowerPoint file that you want to convert, choose the option that you want to use before clicking Open. (You may need to click on Options in the lower left to show the import options that are available.)

Import SongSelect

Choosing this option loads the QuickSearch window already in the SongSelect tab. SongSelect is owned by Christian Copyright Licensing International (CCLI). If you are an active license holder of a CCLI license for your church or organization then you have the option of purchasing a subscription to SongSelect.

For more information about CCLI and SongSelect, visit www.ccli.com.

If you have access to SongSelect, ProPresenter can store the registration information for you and provide direct access to SongSelect through the program. This makes it easy to get songs from SongSelect without having to leave ProPresenter.

To use SongSelect, please make sure that the Show House of Worship Integrations option is enabled in the General tab of ProPresenter Preferences. You will be prompted to login to your account upon first searching in the QuickSearch window or by going to the Services tab of ProPresenter Preferences and clicking the Login button under SongSelect.

ProPresenter allows you to search for songs from SongSelect in the QuickSearch window. To do this, click on Search in the toolbar or go to File>Import>SongSelect... to access this window. You can search here by title, author, keywords, or CCLI number.

Once you search for a song, you can highlight it and a preview will show of the song lyrics and then simply click Import to begin the import process of the file.

Songs downloaded from SongSelect are also stored in a CCLI Reporting file. You can access this file in the General tab of ProPresenter Preferences by clicking Reporting in the bottom right corner of the window. This file can be exported and/or reset at any time and shows the date the file was downloaded, title of the file, author, publisher, copyright year and CCLI number for the song.

Copyright information is also downloaded from CCLI and there are ways to send this to your Screen when that presentation is triggered. More information on this is found in the Copyright Display section here.

Import Media

This option will load a computer browse window where you can search for the media files you wish to import. Navigate to the media file you wish to import and select it. The file will be added to either the Audio or Media Bin depending on its file type and will add into whichever Playlist is currently selected in the respective Bin.

Import ProPresenter Library

This area allows you to import any previous ProPresenter6 or current ProPresenter libraries and migrate them into the program. You will see a window showing any Library from Pro6 that is currently able to be located on your machine provided ProPresenter6 is installed on your machine. This will allow you to select a library to import and convert to ProPresenter. Importing these files does not affect your previous files, so you can import the files while you are getting ProPresenter configured without affecting the previous versions. More information on this is found in the Migration section below.

Exporting

There are several ways and formats to export an individual document or multiple documents that have been selected from the ProPresenter program.

To access the Import options inside of the program, go to File>Export in the menubar and select one of the options from the submenu.

Export Presentation

Exporting as a Presentation file will include simply the text slide data itself and will not include any media that is used in the Presentation.

Export Presentation Bundle

Bundles are used to gather Library files and media files together into a single package that can be opened in ProPresenter on another computer. If you select multiple songs in the Library, they will all be included in the same bundle along with the media. Importing a bundle file will prompt you to add the documents to a Library

Export Text

This option will export the select presentation(s) as a plain text file with a .txt extension. This export method strips all formatting except line and paragraph breaks.

Export Slide Images

This option will export all slides in a presentation as a JPG or PNG image. The JPG image will include any slide background color you've selected, while the PNG will not include the slide background color.

You can also choose whether you wish to include thumbnails of your Media Actions or not. Once you click Save, a folder will be created in your file's destination with individual images of each slide inside.

Export Playlist

This option will export the selected playlist. When you export a playlist you can choose to include the media with the playlist if you want. Importing a playlist on another computer will rebuild the playlist exactly the way it is on the original computer. Playlists can also be exported by right-clicking on the playlist name and choosing Export.

Export Themes

ProPresenter makes it easy to export Themes to be used on another computer. Instead of having to search through the computer folders to find these files and manually add them on another computer, you can export specific Themes to a single bundle file.

Simply check the box next to each of the Themes you wish to export. You can also use the All or None options to select these Themes from the list. By default, all Themes will be selected when you open this window.

When you double-click the exported Theme file on another computer, the Themes will be imported and be available for immediate use.

Migration

There are a few different types of Migration that may occur with your ProPresenter files. This would include migrating from a previous ProPresenter version or migrating to a new computer with your current ProPresenter installation. We will describe options for both of these here.

Migrating from a ProPresenter6 Installation

Initial ProPresenter Install

When you initially launch ProPresenter, you will see the Welcome to ProPresenter series of screens that allow you to do a quick/initial setup of the program. In this window is also an option to migrate existing ProPresenter6 data into the ProPresenter program. You can also access this setup process by going to Window>Welcome to ProPresenter in the menubar.
Here, you will see your existing Pro6 Libraries that are found on the computer provided ProPresenter6 is installed on the machine. You will also have the ability to enable migration of Library Playlists, the Media Bin, the Audio Bin and various Settings/Support Files here.

Once you click on Migrate, your migration process will begin automatically at that time.

Migration Using the File Menu

Migrating via the File menu is similar to migrating through the Welcome to ProPresenter window, but is simply accessed differently. To open this migration window, go to File>Import>ProPresenter Library.

This loads a Migration window that will show each of your previous Pro6 Libraries provided Pro6 is installed on the machine.
You can choose to migrate your Libraries, migrate the Playlists for the selected Libraries, migrate the Media and Audio Bins from Pro6 and also any Settings/Support Files in this window.

Once you click on Start Migration, the program will begin to bring the data into ProPresenter automatically.

Migrating ProPresenter from One Machine to Another

To move ProPresenter data from one machine to another, you can use the Local Sync feature inside of ProPresenter Preferences. It's recommended you have the same version of ProPresenter installed on both machines for this to work properly.

On the Original Computer...
  1. Create an empty folder on the Desktop and name it "ProPresenter Sync" (or something similar).

  2. Open ProPresenter, open Preferences, click on the Advanced Tab, and make sure that "Manage Media Automatically" is checked.

  3. Click on the Sync tab

  4. Click the "+" near the top right and select the new folder you just created on the Desktop. Also, check all five check boxes below that. If you are not moving everything, you would choose which components you wish to migrate here.

  5. Select the option to "Sync files up to repository". This will add all of your data to the folder. (Right now the "Replace Files in Repository" box is irrelevant because the folder is empty.)
  6. Click Sync. Note that this may take a minute or two depending on how much media you have.

  7. Once the Sync operation completes, copy this folder to an external drive or a network drive.

You can now move to the new computer

On the New Computer...
  1. Copy the folder from the external drive or the network drive to your Desktop.

  2. Open ProPresenter, open Preferences and then click on the Sync tab

  3. Click the "+" near the top right and select the folder you just copied to the Desktop. Also, check all of the boxes you had enabled on the original computer.

  4. Select the option for "Sync files down from repository". This will make sure that your data gets copied from the folder to your ProPresenter folders.
  5. You would only wish to enable Replace My Files if you want the program to remove what is currently there before adding what is coming across from the original computer

  6. Click Sync. Note that this may take a minute or two depending on how much media you have.

Your data should now appear inside of the program on your new machine.

Printing

ProPresenter provides a way for you to print out your Slides and Playlists. This section will cover all of the Printing options inside of ProPresenter.

Printing one or more Presentations

To print your Presentations, select one or more Presentation and choose one option:

  • Press Command-P on Mac or Control-P on PC
  • In the Menubar select File > Print
  • If the presentation(s) are inside of a Playlist: right click on the presentation and choose Print

Printing a Playlist

You can print an entire Playlist which will print each Presentation in that Playlist. To print a Playlist, right click on the Playlist and choose Print Playlist.

Printer Options

When you tell ProPresenter to print it will bring up the Print Options Box. This process is slightly different between Mac and Windows, and the platforms are separated here below.

Mac

The top half of this window is controlled by the operating system and will be customized based on your printer. Use this section to choose which printer you will be printing to, the paper size, and other similar options.

Tip: If you would like to "print" to a PDF, click the **PDF** dropdown in the lower left and choose **Save as PDF**.

ProPresenter's options are on the bottom half of the window. If you don't see these options, click the Show Details button at the bottom of the Print Dialog Box. More on these Details is available below...

Once you've setup the parameters of how you'd like to Print, you can click the Print button.

Windows

ProPresenter's options are on the first window. This allows you to set the parameters of what will be printed. More on these Details is available below...

Once these details are set, you can click on either Print or Preview to move forward. Clicking on Preview will show a PDF preview of your printout, while Print will open the computer printer window. This window is controlled by the operating system and will be customized based on your printer. Use this section to choose which printer you will be printing to, the paper size, and other similar options.

Once you've setup the parameters of how you'd like to Print, you can click the Print button.

Parameters on Printouts

There are two main ways to print your Presentations:

  • Thumbnail View will print images of each of your slides; this is preferable if you are wanting visual representations of each slide (including media and all slide objects)
  • Outline View will extract the text from each slide and print it as text; this view is better if you are printing lyrics or otherwise just need the text from your presentation

Each of these Views offers several options to help customize what you are printing. Click the check box next to each item to toggle the printing of that option.

Both Views have the following options:

  • Document Information: Prints information such as:
    • Artist
    • Author
    • Publisher
    • Copyright Year
    • Song Number
  • Presentation Notes
  • Current Date

The Thumbnail View also has this option:

  • The number of Columns that the thumbnails will print in

The Outline View also has these options:

  • Slide Numbers
  • Slide Labels
  • Slide Notes
  • Disabled Slides