Documentation
Tutorials
Download

Other Features

ProPresenter has many different features that allow you to modify how you create presentations, how you trigger them to your screen and what specifically goes into those slides. As you dig into each of these items, you'll see new and exciting ways to convey your messages across to those viewing your presentations!

The Announcement Layer

The Announcement Layer gives you the ability to have a second presentation running simultaneously with your normal presentations for your service or show! For example, if you have screens in your lobby that you want to send an announcement loop or other content to during a service or show, you can use the announcement layer to do that from the same computer!

Setting up a presentation to be an “Announcement Presentation” is as quick as pressing a button. In the Presentation Header, there is an icon that looks like a target that denotes whether the Presentation is seen on the Announcement Layer or the Presentation Layer.
If you click on this button, you will see three options. The first is Presentation and is what all presentations have selected by default. The second is Announcements. If you choose this, that icon will turn green and this presentation will now playback on the announcements layer. And lastly, Edit Looks which allows you to manage which layers of ProPresenter are going to each screen.

Now that you have the presentation assigned to the announcements layer, you’ll have to tell it to show up on the appropriate screen. This is done by setting up an Audience Look to send the proper layers to the proper Audience Screens. More information on setting up your Look can be found here.

Sending to the Announcements and Presentation Layer at the same time

To make the Announcements layer run continuously while you are running the rest of your presentations, set it up with Go To Next Timers with the last slide having the box to “Loop to Beginning” checked.

Then, you can start that Presentation and then click on any other Presentation (that is set to send to the Presentation Layer) and that will send to your other Audience Screens while not affecting the Announcements Layer.

Audio Routing

ProPresenter allows you to route your audio to any output that the computer can see. For example, if you want all of your audio to go to a specific device or output, you can route it in the Preferences to go there. You can also route specific channels of audio to specific output channels.

In addition to simple default setups (Channel 1 is Left, Channel 2 is Right, etc.), ProPresenter is capable of fully customizing your audio setup. Clicking on Channel Routing in either the Preferences or the Cue Inspector will bring up a window that allows this custom routing.

Audio Routing via Preferences

You can access the general Audio Routing section in the Audio tab of ProPresenter Preferences.

The left side of the Audio Routing window shows you one Pro Channel for each Channel Count set in Preferences. Click on the channel name to rename it. To the right are 16 channels that you can output to. Not all devices support 16 channels, so selecting cells in columns higher than your device supports may result in unpredictable results.
Click on the cells where you want the audio to be heard. For example, if you want ProPresenter’s Channel 1 to output to Channel 3 of your output, click on the cell at the intersection of those two selections and the box will light up. To turn off a cell, click on it again.

Click on the M next to a channel to Mute that channel. Click S to Solo that channel. Click T to send a Tone to that channel. You can turn on and off as many of these features at the same time as you would like.

In the top left you can click on the M to mute all of the channels. If you have one or more channels soloed, click the S in the top left to turn them all off at the same time. Click on the Mapping drop-down and select Auto to autofill the cells or Clear to remove all of the selected cells.

Audio Routing via Cue Inspector

You can access individual Audio Routing for a specific Media Action in the Cue Inspector's Audio tab. You will only be able to access the Audio tab if the Media Action you're viewing in the Inspector has an Audio channel on it.

The Routing window that is accessible from the Inspector is more basic than the Preferences version, however the core functionality is the same. The left side lists all of the audio channels for the piece of media that is selected. The top lists the audio channels that are available in ProPresenter (set up in the Preferences). Click on the cell of the row/column that you want the audio to play in. Click on the Mapping drop-down and select Auto to autofill the cells and Clear to remove all of the selected cells

Bibles

ProPresenter features a robust Bible browser allowing you to quickly search (via passage or keyword), curate, and show to the screen passages out of the Bible.

Bibles work off of Templates, so first you will need to create a Template that your Bible will use (or you can select one of the example Bible Templates that are included with ProPresenter). Once you have selected the desired Template you can select the Bible version(s) that you would like to use, then search for a passage or keyword. After you find the desired passage you can show the passage directly to the screen, or you can save the slides out as a Presentation that can be added to a Playlist for easy organization into your service.

Bible Pane

The Bible Pane is where you will search for passages as well as set options for how the Bibles will look on the screen.

Open the Bible Pane through one of the following options:

  • Click the Bible icon in the Toolbar
  • Press Control-B on Mac or Control-Alt-B on PC
  • In the menubar select View > Bibles

Close the pane by choosing one:

  • Click one of the other buttons in the Toolbar (such as the Show, Edit, or Reflow View)
  • Press Control-B on Mac or Control-Alt-B on PC
  • In the menubar select View > Bibles

On the top left of the Bible window is the Scripture Lookup and Search boxes, both used to find Bible passages to show on the screen. To the right of the search box is the Options button; click this button to customize how the Bibles are shown on the screen (such as selecting the Template that is used when building the Bible slides). Below the search boxes you can select one or more Bible versions to show on the screen. The center area of the Bible window shows thumbnails of the slides based on what you have entered into the Scripture Lookup or Search boxes. Click on a slide to show it to the screen.

Note: You cannot directly edit slides inside of the Bible Window, instead you indirectly create and edit slides through the other features in the Bible Window. If you would like to directly edit a slide that a Bible verse is on, then you will need to save the slide(s) out as a Presentation, as seen below.

In the lower left of the Bible Window is a Save As… button. Click this button if you want to save the currently showing slides out as a Presentation or if you want to copy them to the current Presentation. When you click this box you have three options:

  • Save as Presentation will save the currently showing slides out as a presentation; this is helpful if you want to edit one or more of the slides or you want to create a stand alone Presentation with your Bible slides
  • Copy to Current Presentation will copy the currently showing slides to the currently selected Presentation; use this feature if you are creating sermon slides and want to quickly copy the Bible slides to your Presentation
  • Save to Playlist gives you a sub-menu, allowing you to select one of your Playlists; once you do, it will save the currently showing slides out as a Presentation and add that Presentation to the currently selected Playlist

Next to the Save button is the Transition feature of the Bible Window. This feature controls how the Bible slides will transition onto and off of the audience screen. This transition is specifically used when the slides are clicked in the Bibles window. If you save a Presentation from Bibles, that presentation would then use the default Presentation transition set in the Slide View Area. The Transition feature is covered in depth in the Transition section.

Across the bottom of the Bible window are the < Verse and Verse > buttons. When you click on one of these buttons it quickly adds one verse either before or after the currently showing verse(s). For example, let's say you have Psalm 115:5-7 currently selected; clicking the < Verse button will add the previous verse to the selection, making the selection Psalm 115:4-7, whereas clicking the Verse > button would make the selection Psalm 115:5-8.

Note: These **Add Verse** buttons are also available if you use the Save feature to save a Bible verse out as a Presentation.

Buttons on the bottom right of the Bible Window control how the thumbnails are shown in the center area. You can toggle between the Grid View (shows all slides in a grid) and Table View (shows slides in a column with the text of each slide to the right of the thumbnail) by clicking on the appropriate button. Click and drag the slider to control how large the thumbnails appear in the slide area.

Scripture Lookup and Search

There are two primary ways to search for a Bible passage: by looking up the Bible reference itself, or by doing a text search of the text of the Bible.

Scripture Lookup

You can use the Scripture Lookup box when you know the passage (book, chapter, and verse) that you want to reference. One option for searching this way is to type the reference into the Scripture Lookup box; for example you can type in Matthew 1:2-3 and it will return those two verses.

Tip: Don't know how to spell a book's name? Don't have time to type all of the extra punctuation? No worries! ProPresenter will take what you type and do its best to figure out what you mean. For example, if you type out "Ephes 2 4 6" it will return Ephesians 2:4-6.

The other way to use the Scripture Lookup is to use the drilldown menu. Click on the down arrow on the right side of the Scripture Lookup box and manually navigate to the reference you are looking for.

Tip: Using the drilldown menu you can select one verse, one whole chapter, or even an entire book! If you use the drilldown menu and want more than one verse, then either click on the chapter number to get back the entire chapter, select one verse then use the Add Verse buttons at the bottom of the Bible Pane to add a few verses to your selection, or select one verse then manually change the Scripture Lookup box to match what you are looking for.

Search Box

You can also contextually search your Bibles to find a specific passage based on text.

Type in a word in the Search box and press return/enter. You will see a window appear with a list of all of the instances that that word appears in the currently selected Bible. Find the passage you would like to show on the screen, then on the right side of the scripture reference click either Verse or Chapter to generate slide(s) with only that one verse or the whole chapter that the verse is contained in.

Note: If you have more than one Bible selected in the Bible Version section of the Bible Window, by default it will search the one that is listed first. If you would like to search one of the other Bibles, click the down arrow that is inside of the Search box to select a different Bible.

Bible Options

Use the Options button in the top right of the Bible Window to control how Bible will render the verses onto the slides as well as to install new Bibles.

Click on the Options button to open the Options window, then click either Slide Options to control how ProPresenter will render the verses or the Bible tab to install Bibles.

Slide Options

The Slide Options tab of Options allows you to control how ProPresenter will present the slides on the screen.

Click on the down arrow next to Theme to control which Template slide will be used when rendering the text. For more information on how to create a Bible Theme, see the Bible Theme section below.

On the top left of the Slide Options window there are several options:

  • Show Verse Numbers will toggle the inclusion of the verse numbers within the text that is being shown
  • Break on New Verse will, if checked, only have one verse per slide (instead of filling the text box and then breaking to a new slide)
  • Display Transition will, if checked, include the abbreviated version name in the Bible reference; as an example: "Matthew 1:2-5 (NIV)"
  • Preserve Font Color will keep the font color of the Bible if present (useful for Bibles that have Jesus' words in red letters)

The top right options control how (if at all) the scripture reference will be included.

  • Verse References is only available if Break on New Verse is selected and will show each individual verse with each slide (IE: Matthew 1:2, Matthew 1:3, Matthew 1:4, etc.)
  • Passage Each will show the entire reference (IE: Matthew 1:2-5) on every slide
  • Passage Last will show the entire reference (IE: Matthew 1:2-5) only on the last slide
  • No Reference will hide the scripture reference

Note: If you have a Reference text box selected then the scripture reference will be included in that text box. If no Reference text box is included, then the scripture reference will be included as a separate line at the bottom of the Verse text box.

At the bottom of the Slide Options window, select the Import Library which is the Library that your Bible verses will import into if you create a new Presentation with Bible verses.

Downloading and Installing Bibles

You can download, install, and manage installed Bibles via the Bibles tab of the Option window. Click on the Purchased tab to see available paid Bibles and the Free tab to see available free Bibles.

Note: To see Purchased Bibles you must first register ProPresenter.

Scroll up and down either of the tabs to find the Bible you are looking for. Click the Install button to install the Bible. If you have already installed a Bible, click the Remove button to delete the Bible from your computer.

Bible Themes

ProPresenter uses the Theme feature to format and render Bible slides. You can set up as many Template Slides as you want, and, while any Theme can be used for rendering Bible slides, there may be reasons to format Template Slides that will be used for Bibles slightly differently.

When you are setting up a Template Slide for use with the Bible feature, remember that you will need a text box for the text of the Verse and, optionally, a separate text box for the scripture Reference. If you are using multiple Bible versions at once, you will want a separate text box for each Verse as well as (optionally) a text box for each Reference.

Tip: Remember that in ProPresenter, all Objects are Text Boxes, so even simple shapes on the Template Slide can be selected as containers for your text. Once you have set up your Theme to have one or more text boxes/objects, you will need to select this Theme to be used by the Bible feature. Open the Bible tab, click on the Options button on the top right, click on the Slide Options tab, then at the bottom of the window select the Theme that you would like to use.

You will now need to assign your Verse(s) and Reference(s) to the desired text boxes/objects. At the top of the Bible window, on the left select the desired version from the dropdown menu that contains all of the versions that are installed on your computer. Next, click the dropdown next to Verse: and select which text box/object you would like your verse text to appear in. Optionally, next to Reference: select the text box/object that you want the scripture reference to appear. For Reference, you can also select With Verse if you'd like the Reference to appear in the same text box as your verse with the same formatting.

Multiple Bible Versions

ProPresenter allows you to show multiple versions of the Bible on one slide without having to copy and paste text on every slide. This is perfect for multi-lingual churches, as well as churches that want to compare and contrast multiple Bible versions.

First you must have more than one Bible version installed on your computer. Next, just below the Options button on the top right, click on the + to add additional Bible versions. You can add multiple versions, limited only to the number of Bibles that are installed on your computer.

You can now click the dropdown boxes on the left to select which Bible versions will be used and click the dropdown box next to Verse: and Reference: to select which text box/object will be used for each section. You will likely want to create a custom Template with multiple Text Objects to set for the verses of the different translations.

Click the - button to remove a Bible version.

Calendar

The Calendar allows you to schedule Presentations inside of Playlists to fire at specific times of the day, specific dates, and/or reoccurring days of the week. This feature is great if you want a countdown to start five minutes before an event or if you want a slideshow to change at a specific time, just to name a few examples.

To open the Calendar window:

  • Press Control-Option-C on Mac or Control-Alt-C on PC
  • In the menubar click View > Calendar.

    Calendar Window

To toggle all Calendars on or off:

  • Click the Calendar Enabled checkbox across the top of the Calendar window;

  • Press Command-Option-S on Mac

  • Select Calendar > Enable Calendar from the menubar.

The left side of the window will list all of your Events and the right side shows you information about the currently selected Event. If there is an Event that is currently active, you can select it by clicking the Go To Current button.

The Show/Hide Reoccurring Events button toggles how repeating Events are shown in the left pane of the window and looks different based on what is currently being shown: this can be set where only one copy of each Event will be shown or where every occurrence of a repeating Event will be shown.

Events

An Event is a single or reoccurring Action that fires at a given day and time. You can assign a specific Playlist or Presentation within a Playlist to fire at the designating date and time; think of it as the program clicking on the first slide of a Presentation for you at a specific time.

To create a new Event:

  • Click on the + button in the bottom left of the Calendar window;
  • Press Option-Command-N on Mac
  • From the menubar select Calendar > New Event.

To delete an Event, select it in the Calendar window and press the delete key or, if you have a trackpad, you can use two fingers and swipe to the left on the name of the Event and then click Delete.

If you are deleting an Event that has more than one occurrence it will ask you if you want to delete only that one occurrence or all occurrences of the Event.

You can customize an Event’s Name and Description at the top of the Calendar window when an Event is highlighted by simply single clicking on these headers. Below that is where you set the Event’s scheduled time to Start; each Event must have a date and a time that it will become active.

Next to Repeat you can select days of the week that you want the Event to repeat. If you select one or more days of the week then you can optionally set a date and time for the Event to End On.

At the bottom of the window you can select the Action which will control what happens when the Event fires; you can select a Playlist or a specific Presentation within any Playlist. Click on the Test button to immediately see what will happen when the Event activates. If you select a Playlist, the Scheduler will trigger the first item in the Playlist. If this is a Presentation, it will fire the first slide.

Communications

ProPresenter provides connectivity to external devices via network or serial communications according to what the protocol supports. There are a number of different protocols which can be organized into three groups including the following: AMP, VDCP, Sony BVW, GVG100, Sony BVS, GlobalCache, RossTalk, DMX, and MIDI.

The Windows version of ProPresenter offers Midi Communication only while, Mac offers Midi and all other protocols discussed below.

To add any of the available protocols to ProPresenter, click on the Add Device button in the lower right corner of the Devices tab of ProPresenter Preferences and select the protocol from the list. Each protocol has unique configuration settings. We have set each protocol to use the standard configuration as specified by each manufacturer. If your configuration requires different settings you will need to refer to the documentation for the device you are connecting to with ProPresenter. The screenshot below shows GVG100 as an example.

After you have added a protocol, you will see a box that shows you the active protocols. You can connect or disconnect any protocol, or remove it, from here. If you need to change the settings for a protocol, click on the gear icon to open the settings menu.

Click on MIDI Setup or DMX Setup to modify these protocols.

The following screenshot shows several of the protocols listed at the same time. ProPresenter is capable of supporting more than one protocol at the same time, within reason. Some protocol combinations don't make sense to run at the same time, like AMP and VDCP, but some do like AMP and RossTalk.

Midi Communication

The MIDI configuration allows you to auto-fill all the commands from a starting note, or you can assign any MIDI note to a given command. You must ensure that you don't assign the same MIDI note to multiple commands since this will result in undefined behavior.

Click on the Device menu in the lower-left corner of the Devices tab of Preferences and add a new MIDI device. Select the correct device that you have setup to be used with your computer. Click Save and then Connect after you have finished configuring the rest of the MIDI settings. Click on the MIDI Map button to open the MIDI communication settings. MIDI notes range from 0 to 127. Entering a number next to Auto Fill and then clicking the button will fill all of the values beginning with your chosen value. If you want each section to start at a different, type your starting value in the first box of each list and then click the Auto Fill using the first value in each Form button at the bottom.

MIDI values cannot be shared between commands. For example, you could not assign All: 48 and Next Playlist: 48 at the same time.

ProPresenter also allows any slide to have a MIDI cue attached to it which will generate a MIDI note when that slide is clicked.

To add a MIDI cue, right-click on a slide and select Add Cue > Communication Cue > MIDI and select either MIDI Note On or MIDI Note Off. For each MIDI cue, you can specify the MIDI Channel, Note and Intensity.

DMX Communication (Mac Only)

The DMX configuration allows you to define the starting channel and displays how the other channels are mapped. DMX supports ArtNet over a network only. USB-DMX interfaces are not supported. The screenshots below show a standard DMX setup. These values are entered by clicking on the DMX Setup button in ProPresenter Preferences>Devices.

Playback Deck/Media Server Control Protocols (Mac Only)

These protocols include AMP, VDCP, and Sony BVW. AMP and VDCP are media server protocols that have more capabilities than Sony BVW such as triggering clips by name. BVW can only control the playback of an already triggered clip.

Switcher Control Protocols (Mac Only)

These protocols include GVG100, Sony BVS, and RossTalk. These protocols can control a switcher, allowing you to remotely enable and disable keys or fade to black.

Sony BVS is preferred over GVG100 when available since it has greater capabilities. RossTalk is a proprietary protocol supported by some Ross switchers. RossTalk is the preferred choice for a compatible Ross switcher because it uses network communication rather than serial. RossTalk is supported as 2 modes, Device and Controller. In Controller mode, ProPresenter can send commands to a connected Ross switcher. In Device mode, RossTalk provides some control of ProPresenter from a compatible Ross switcher. For Device mode, the Ross switcher is setup to connect to ProPresenter as if it were an Expression CG machine. Once connected, Up/Down on the switcher will advance through the items of the selected playlist, and next will trigger slides or videos just like pressing the spacebar/right arrow key on the ProPresenter machine. Note that if you want to use both Controller and Device modes for RossTalk, you must configure 2 RossTalk devices, one for each mode as these modes require two different network connections.

ProPresenter makes it easy to display copyright information for songs. When you import a song from SongSelect, the data is automatically filled in. If you create your own song files, you can manually enter the copyright information if you want to. To show Copyright Information, you must have Show House of Worship Integrations enabled in the General tab of Preferences.
There are two places that you need to configure copyright display. The first place is in Preferences at the bottom of the General tab. These are the global settings that apply to every presentation in the library. As you can see, you can choose to show the copyright information on the first, last, first and last, or every slide of your presentation. The second place this must be enabled is in the Slide Editor in the Presentation tab.

The License # box on the right is for you to enter your church’s unique license number. You will need to contact CCLI for this number if you aren’t sure what it is.

To change the copyright elements that are shown (Title, Artist, publishing information, etc.) click on the CCLI Layout... button. This will open the options shown below. Each of the copyright elements are controlled by “Tokens,” a feature in ProPresenter that allows text from one part of the program to be automatically shown by a different feature. The tokens on the left are the active tokens, meaning these are the ones that will be shown. The column on the right shows all of the options available. You can add and remove tokens from the left column by clicking and dragging them in and out of the right column.

Clicking on Edit Template will open the CCLI Editor and allow you to format the position and text settings for your copyright information. Since tokens aren’t actually text, the only thing you’ll see in the text box is the copyright symbol. If you want to see how text will look formatted, add any text you want since this will be replaced automatically.
Once you have configured how you want your copyright information to be displayed, you will need to make sure a presentation has information to display and that it’s enabled. The Copyright section of the Presentation tab of the Slide Editor allows you to set, change, and show the copyright information for the selected Presentation.

Masks

The purpose of a Mask is to allow you to “mask” (or cover up) a part of your output to create custom projection screens or to keep the projector from projecting onto something that you don’t want it to. The Mask is shown on the topmost layer of an Audience Screen

Enabling a Mask

Masks are enabled by using an Audience Look to set a certain Look for your Audience Screen. You can select which Mask you wish to use for each individual screen there. If you would like to create a new Mask, you can click Add New Mask or Edit Masks to access the Masks Editor. For more information on Audience Looks, see that section here.

Mask Editor

You can create and edit Masks via the Mask Editor. Open the Mask Editor by opening the Audience Looks Pane and then in the Mask dropdown menu, go to Add New Mask or Edit Masks

Note: The Mask Editor is very similar to the Slide Editor. This section will only cover parts of the Editor that are unique to the Mask Editor. For general information about the Editor as well as items that are not covered here, please see the Slide Editor section.

Mask Editor Interface

There is no Slide Notes feature in the Mask Editor.

Mask Tab

When no objects are selected on the Mask in the Editor, the Inspector on the right side of the Editor window will show a single Mask tab.
Due to the limited nature of Masks, there are two editable options here.

  • Name -- Here, you can name the Mask and this is the Label that will show on the thumbnail in the Mask dropdown in the Audience Look Pane.
  • Size -- This allows you to set the size of the Mask itself -- typically, this would match the resolution of the screen the Mask will be displayed on.
Object Inspector

When you have an Object selected on the Mask, two tabs will appear in the Editor that are almost identical to those in the original Slide Editor.

Shape Tab

The difference in the Shape Tab is that the Visibility, Shadow and Stroke features are not available.

Text Tab

The only difference in the Text Tab is that the Linked Text feature is not available.

Messages

The Messages feature in ProPresenter is a versatile way of showing extra content on your audience output. This content is independent of the slides and other media inside of ProPresenter, which means it will appear on top of your slides and other content; for example, Messages will stay on top of your slides, even if you change slides. This makes it a preferable way to show content across multiple slides.

Examples of this might be:

  • "Car with License Plate X852WT, your lights are on."
  • "The service will begin in 03:32."
  • "Parents of child 485 please come to the nursery."

Tip: The Props feature of ProPresenter is similar to the Messages feature, but there are some unique characteristics between them. In general, if you want your content to be pre-programmed then you would be looking at a Prop; if you want to make changes to text on the fly then we recommend investigating the Messages feature.

Tokens

To use the Messages feature you will be setting up a block of text that will fill a text box that you set up inside of a Template. This block of text can include prewritten text as well as one or more Tokens, or variable blocks of text.

Using the same examples as before, let's look at what the blocks of text would look like with tokens:

  • "Car with License Plate [License Plate], your lights are on."
  • "The service will begin in [Service Countdown]."
  • "Parents of child [Nursery Number] please come to the nursery."

The above blocks of text and Tokens would be setup beforehand, then when the operator is running ProPresenter live, they would only have to enter the pertinent information inside of the Token and click the Show button for it to appear on the screen.

Note: Messages can be set up on the fly, however they are most powerful when they are set up beforehand so that the operator is able to keep their focus on the rest of the show.

There are several types of Tokens:

  • System Clock: Shows the current computer time
  • Timers: Any Timer that you have set up in the Timer Pane can be sown via a Message
  • Pre-Defined Text: ProPresenter provides some text boxes that are already set up to use, including "Name", "Message", and "Room"; these Tokens cannot be deleted but are otherwise the same as Custom Text tokens
  • Custom Text: Create your own Token with its own name and content

Let's dive into one of the above examples: "Parents of child [Nursery Number] please come to the nursery." In this example, someone had previously set up a Message for this contingency. They created a Message called "Nursery Call" and applied a Template to it. They then created a custom Token called Nursery Number; this is simply a text field that the end user can use to enter the child's number. After they create the Token, they type into the text field "Parents of child please come to the nursery." and they drag the "Nursery Call" Token into the text field which creates "Parents of child [Nursery Call] please come to the nursery."

The Message is now set up and ready to go. The next day, during a service, the operator is notified that a nursery call is needed. They open the Messages feature of ProPresenter, type the nursery number ("485") into the Token area, and click Show. ProPresenter then correctly shows the text "Parents of child 485 please come to the nursery." on the screen.

The Messages Pane

The Messages Pane controls the Messages feature of ProPresenter. Open the Messages Pane by:

  • Clicking the Messages button in the Toolbar;
  • Pressing Control-M on the keyboard
  • Selecting in the Menubar View > Messages.

Close the pane through those same options or by clicking the "X" in the upper corner of the window.

The Messages Pane is by default "docked" to the main ProPresenter window, meaning it can be resized but it can't be moved around. If you would like to undock the Messages Pane then click the Dock button on the top right of the pane. Click the button again to dock it back to the main window.

The default view of the Messages Pane lists your Messages on the left side, while the Tokens of your currently selected Message are shown on the right side of the window.

Create a new Message by clicking the + in the lower left of the window. Delete a Message by clicking on the message and pressing the Delete or Backspace button on your keyboard, or, if you have a touchpad device, swipe to the left on top of the Message name and click the trashcan icon.

Click the Show Web Access button at the bottom of the window to open the webpage where users can send Messages over the network. The Allow Web Notifications checkbox at the top of the window will quickly toggle this feature on and off. See the Web Notifications section for more information.

Click the Modify Transition button to change the transition that Messages will use when they Show and are removed from the screen. All Messages share the same Transition and there is not an option to set individual Transitions on individual Messages.

Click the Show button to Show the currently selected Message to the screen. You can identify which messages are currently being shown by looking for an X to the right of its name in the Message List; click the X to remove the message. To remove all Messages, click Clear All at the bottom of the Message List (only visible when Messages are being shown), click the Clear Messages button in the Preview Window, or in the menubar select Actions > Clear Messages.

Editing a Message

To set up and edit non-Token parts of a Message, click the Edit Message button in the upper right of the window; this will show additional controls for editing the Message itself; click this button again to hide these additional controls.

With the Edit controls showing, on the left is the text box where you can type your message and include any Tokens that you will be using. The right side lists available Tokens; click and drag a Token from the Token List to the box on the left to add that Token to your message. To create your own Custom Token, type the name into the text box below the Token List and click the + button. To delete a Custom Token, click the arrow next to the Token name and select Delete.

Note: The pre-defined Tokens that come with ProPresenter cannot be deleted. Any Clocks/Timers that are created in the Timers Pane will appear as Tokens as well.

Click the Theme to change which Theme this Message will use for formatting when it is shown on the screen. To have a Message clear automatically after a certain amount of time, click the dropdown menu next to Dismiss and select the amount of time before it clears, or select Manually to have it not clear automatically.

Customizing Tokens

The center area (bottom half if the Edit options are open) of the Messages Pane shows all of the Tokens in the currently selected Message. This area lets you quickly and easily change the content of each Token before you Show it to the audience screen.

Here are the Token types and the options you have when editing them:

  • Pre-defined ("Name", "Message", and "Room") and Custom Tokens
    • These are simple text boxes; enter any text you would like and the Token will pass that text through to the Message when it is shown
  • Clock -- this is the standard system Clock
    • Date Format: Choose how the Date will look
    • Time Format: Choose how the Time will look
    • 24 Hour: Click to enable a 24 hour clock, unclick to enable a 12 hour clock
  • Timer -- this will appear for Timers setup in the Timers Pane
    • Timer Type: Click the dropdown menu to select if the timer is a Countdown timer, a Countdown to Time timer, or an Elapsed Time timer
    • Countdown timer: Duration allows you to select how long the timer will be
    • Countdown to Time timer: Choose the Time at which the tier will countdown to, then select the Format (AM, PM, or 24 Hour) you are using
    • Elapsed Time: Choose then number at which the timer will Start and End.
    • Overrun: Check this box if you want the timer to continue to count after it hits its destination, uncheck it if you want it to stop at its final goal
    • When a Timer is running click the Reset Timer button to reset the timer, Start Timer button to start the timer, or Stop Timer button to pause the timer
    • You can also choose how the timer will be shown on the screen. There are options for hours, minutes, seconds, and milliseconds. For each of these options you have up to five choices; however depending on what you have selected in one section might disable options in another section. Here are the five options, using hours as an example:
    • h: Always show the hours but hide leading zeros
    • hh: Always show the hours and show leading zeros
    • h: If there are hours then it shows them with no leading zeros; if there are no hours then it doesn't show them
    • hh: If there are hours then it shows them with leading zeros; if there are no hours then it doesn't show them
    • - -: Hide the hours text; if there would be hours to show it adds that time to the minutes

Web Notifications

You can configure ProPresenter to allow other people to send Messages over a local network. Using this feature allows other users on any internet enabled device to load a web page, make changes to the Tokens (just as the operator would inside of ProPresenter) and send a request for that Message to be sent to the audience screen. The operator running ProPresenter can either approve or disprove the showing of that Message.

Before this feature is utilized you must enable a feature inside of the Preferences. In the top left of the screen click on ProPresenter then click on Preferences. Click on the Network tab and make sure that Enable Network is checked. It will automatically generate a Network Name and Port; you can change the Network Name if you would like, we recommend leaving the Port number alone unless there is a specific need to.

Now that the Network is enabled, close the Preferences window and open the Messages Pane. You can toggle Web Notifications by clicking on the checkbox next to Allow Web Notifications.

Click on the Show Web Access button across the bottom of the Messages Pane to open in your default browser the web page where you can access the Web Notification feature. Make a note of the web address and share it with users who you would like to be able to send Web Notifications. For example, you can copy the web address from the browser and paste it into an email to someone who should have that access.

Sending Web Notifications

To send a Web Notification the sender will need to open the web address provided to them on a device that is on the same network as the computer running ProPresenter.

Note: The user's device that will be accessing this feature must be able to see the device running ProPresenter on the network. Generally speaking this means that the devices need to be on the same wired or wireless network as each other, however each network is unique so you may need to speak to your network administrator about how to enable a feature like this. Once they open that webpage they will see a list of all of the Messages listed inside of ProPresenter. They can add text and make other changes as necessary to their desired Message, then click on Show. This will send a request to the ProPresenter operator to show the Message on the screen.

Receiving Web Notifications

When a Web Notification is sent the ProPresenter operator will see a notification on the top right of their computer screen notifying them of the request. The notification works slightly differently between Mac and Windows. To show the Message on the audience screen on a Mac, click Show Alert, to dismiss the request on a Mac and not show it on the audience screen, click Dismiss. To show the Message on the audience screen on a PC, click directly on the notification, to dismiss the request on a PC and not show it on the audience screen, click the arrow to "archive" the notification.

Once approved the Message will show on the Audience screen just as if the ProPresenter operator had shown the Message. It will follow all of the same rules and can be cleared the same way as other Messages.

Message Actions

Add Message Actions to slides to show specific Message(s) when you click on a specific slide. Add Message Actions to slides by opening the Action Palette and dragging the Message Action onto a slide. When adding or editing a Message Action you will be able to select which Message you want to fire when that slide is clicked, as well as be able to edit any variables that you have set up inside of that Message.

You can have multiple Message Actions on one slide.

Props

There are many times where users have a need to put a persistent image or some text on top of one or more slides. Some examples of these types of needs are:

  • A logo (often times called a "bug") in the lower corner of the screen
  • A mission statement or other text that will be shown across multiple slides
  • An icon during the last verse of a song telling children to come to the front of the sanctuary for Children's Time

The Props feature of ProPresenter was created to address these needs and much more!

Props are a way to show text and media on top of the Slides layer and have that text/media persistent across one or more Slides. You can create multiple Props, show one or more at a time, and even control them via Cues on slides.

Props Pane

Props are created, edited, and can be shown via the Props Pane. You can open this window by clicking the Props button in the Toolbar, pressing Control-P on Mac or Control-Shift-P on Windows, or selecting in the Menubar View > Props. Close the pane through those same options or by clicking the "X" in the upper corner of the window.

The Props Pane is by default "docked" to the main ProPresenter window, meaning it can be resized but it can't be moved around. If you would like to undock the Props Pane then click the Dock button on the top right of the pane. Click the button again to dock it back to the main window. The left side of the Props Pane lists any Props that are currently "Live" (showing) on the audience screen. Click the X to clear an individual Prop. To clear all Props, click Clear All at the bottom of the Live pane, press F4, click Clear Props on the Preview Window, or in the menubar click Actions > Clear Props.

The right side of the Props Pane shows all available Props. Click on a Prop to show it live on the audience screen. Select a Prop by holding the Command key and clicking on one or more Props. Once selected you can Copy, Paste, and Delete the selected Prop(s) by right clicking on one of the props, pressing the appropriate keyboard shortcut, or going to the Edit menu in the menubar.

On the bottom right of the Props Pane click and drag the slider to make the thumbnails larger or smaller. Click the Transition button to set the transition for all Props.

Props Editor

You can create and edit Props via the Props Editor. Open the Props Editor by opening the Props Pane then clicking the Edit Props button at the bottom of the window.

Note: The Props Editor is very similar to the Slide Editor. This section will only cover parts of the Editor that are unique to the Props Editor. For general information about the Editor as well as items that are not covered here, please see the Slide Editor section.

Props Editor Interface

There is no Slide Notes feature in the Props Editor.

Prop Tab

When no objects are selected on the Prop in the Editor, the Inspector on the right side of the Editor window will show a single Prop tab.

Due to the limited nature of Props, there are four editable options here.

  • Name -- Here, you can name the Prop and this is the Label that will show on the thumbnail in the Props Pane and also on the left side of the Props Pane when the Prop is Live
  • Background Color -- Note that using the Background Color in Props only affects the Props Editor and Pane to help you to see your content better, it will not change the output to the audience screen.
  • Size -- This allows you to set the size of the Prop itself -- typically, this would match the resolution of the screen the Prop will be displayed on.
  • Transition -- This will control the Transition for the currently selected Prop (Slide). Each Prop can have its own Transition, which will trump (replace) the Transition that is set in the Props Pane.
Object Inspector

When you have an Object selected on the Prop, two tabs will appear in the Editor that are almost identical to those in the original Slide Editor.

Shape Tab

The only difference in the Shape Tab is that the Visibility feature is not available.

Text Tab

There is no change in the Text Tab in the Props Editor.

Props Actions

You can quickly add [icon] Prop Actions to slides to show specific Prop(s) when you click on a specific slide. Add Prop Actions to slides by opening the Action Palette and dragging the Prop Action onto a slide. When adding or editing a Prop Action you will be able to select which Prop you want to fire when that slide is clicked.

You can have multiple Prop Actions on one slide.

Timeline

The Timeline allows you to sequence and playback your slides with or without an audio track. This makes it easy for you to create presentations with custom timings between slides or to record the slides to match a song. The ability to sequence slides with music is especially useful for worship leaders who don’t have a band or someone to run lyrics for them since the song and lyrics can be started with a single click. You can open the Timeline for a given Presentation by clicking on the Timeline button in the Presentation header.

There are two ways to add slides to a Timeline. The first is to drag the thumbnails from the presentation to the Timeline. The second way is to click the Record button and record the slides live. Recording a Timeline is specifically helpful if you're looking to link the slides to an audio track.
Audio files can be added to the Timeline by dragging a file from the Audio Bin or dragging a file from the computer to the Timeline. After you have added an audio track, you’ll see a solid green bar with the song name added below the slides.

You can right click on the audio track to access a few menu options. You can go to the Inspector... which allows you to modify the Audio Cue itself. More information on the Audio Cue Inspector can be found here. You can also Remove or Replace the audio track here if needed.

To record the slides live, click on the Record button to ready the timeline for recording, then press the play button when you are ready. If you have added an audio file, the audio will begin playing. To record slides to a Timeline, click on the slides like you normally would when going through a presentation. When you have finished recording a presentation, click the record and playback to stop the recording. If you need a Timeline to loop, click on the Loop button to the right of the Record button.

Timers

Many users need timers to keep track of services or events. A band wants to know how long until they need to start playing. A pastor wants to know how long he has been talking. Attendees want to know how long before the event starts.

ProPresenter can create and track multiple timers at the same time, and there are various timer types to cover your various needs.

Timers can be used in multiple places in ProPresenter. For example, you can show them on the Stage Display, or use a Message or Linked Text to show them on the audience screen. You can also use Cues to start, stop, and reset Timers as needed.

Note: This section only covers the Timers pane where you can create and edit Timers; for more information on other features that use the Timers, see that respective feature's section.

Timers Pane

The Timers Pane controls the Timers inside of ProPresenter. Open the Timers Pane by:

  • Pressing Control-T on a Mac or Control-Shift-T on a PC
  • Selecting in the Menubar View > Timers

Close the pane through one of the options by which you open the pane or by clicking the "X" in the upper corner of the pane.

The Timers Pane is by default "docked" to the main ProPresenter window, meaning it can be resized but it can't be moved around. If you would like to undock the Timers Pane then click the Dock button on the top right of the Timers pane. Click the button again to dock it back to the main program window. There are three types of Timers:

  • Countdown: Set a specific amount of time for it to count down from
  • Countdown to Time: Set a time of the day and ProPresenter will count the time left to that specific time (based on the computer's internal clock)
  • Elapsed Time: Count up; you can start from zero or include a Starting time, and you can optionally set an Ending time

Create a new Timer by clicking the + in the lower right of the pane. Delete a Timer by right-clicking on the Timer and selecting Delete or, if you have a trackpad, swipe to the left and click Delete.

Click the disclosure triangle to show or hide the Timer's options. Rename the timer by clicking on the name of the Timer. Click on the icon dropdown menu to change the type of Timer.

Check Overrun if you would like the Timer to keep running after it reaches zero or its end; uncheck Overrun to have the Timer stop when it reaches its end. Click the Reset button to reset the Timer, and click Start/Stop to start or stop the Timer as needed. You can affect all of the Timers at the same time by clicking the Stop All, Reset All, or Start All buttons as needed.

Transitions

ProPresenter has a robust Transition feature that allows for media and slides to be transitioned to and from the screen in many creative ways.

Tip: Generally speaking, if you see a Transition icon colored orange then it is in reference to a transition that affects the Slide Layer, whereas purple icons represent the Media Layer.

Transition Hierarchy

The first important concept for Transitions is the hierarchy of how ProPresenter decides what transition to use.

Let's start with talking about slides and how ProPresenter decides what transition to use when you click on a slide:

  • Master Slide Transition: Across the bottom of the Slide window there are three transition buttons which determines the Master Slide Transition; think of this as a "default transition" that all slides will use unless there is reason to use a different transition
  • Presentation Transition: Across the top right of the Slide window there is another, similar button which determines the Presentation Transition; if this is set then all slides in this Presentation will use this transition, if this is not set (if it is set to the Default position) then slides in this Presentation will default back to the Master Slide Transition
  • Individual Slide Transition: Each slide can have its own Transition (added by right clicking on a slide and choosing Transition); this setting will override any Presentation Transition as well as the Master Slide Transition

The hierarchy for media is very similar:

  • Master Media Transition: Across the bottom of the Media Bin (or the bottom of the Slide window if the Media Bin is closed) is the Master Media Transition; this is the default transition for all media
  • Individual Media Transition: All Media Actions (be it in the Media Bin or as an Action added to a Slide) can have their own transition which trumps the Master Media Transition. This is set in the Media Cue Inspector.

There are other features of ProPresenter where you may see the Transition feature, but they all follow similar rules as have been laid out here.

Transition Window

There are many features that use Transitions in ProPresenter, and thus there are many ways that you can open the Transition Window. For example you can click the Master Slide Transition button across the bottom of the slide view. With the window open, click one of the transition thumbnails to select it. Scrub your mouse over a Transition thumbnail to see a preview of that Transition.

On the top left of the Transition window there is a dropdown menu where you can select a subset of transitions to view. Type a phrase in the Filter field to search for available Transitions. In addition to an organized list of available Transitions there is also at the top of the list your Favorite Transitions and Recent Transitions. (To clear your Recent Transitions, click on Clear to the right of the Recent Transitions section.)

With the exception of the Cut Transition, all Transitions allow you to set their Duration, and many Transitions have other parameters that you can adjust. Click Reset to Default Parameters to reset all of the parameters to their default setting. Click on the star to create a Favorite Transition.

If you want to disable a Presentation Transition (so that all slides in that Presentation use the Master Slide Transition), click the word Default in the upper left of the transition window.

Favorites

You can set up multiple Transitions to be your favorites so that you can quickly use them throughout the program. To create a Favorite, select a Transition, set the parameters as you would like, then click the star icon to add it to the Favorites list.

Tip: You can have the same transition type multiple times as favorites (say, with different parameters); just create a favorite as normal, then select the transition again in the main Transition window and you can select the star again to create another copy of that type of transition.

To change the name of a favorited transition, select that transition and, on the right above the large preview window, click on the name of the transition.

After selecting a favorited transition, click the star on the top right to create a copy of that favorited transition ("Save As") or to Remove (delete) that transition.


List of Transitions

Below is a list of transitions that are included in ProPresenter:

Blurs

  • Dispersion Blur
  • Noisy Zoom
  • Zoom In

Color

  • Color Burn
  • Color Push
  • Color Warp
  • Film Burn

Dissolves

  • Dissolve
  • Fade
  • Fade Black
  • Fade Bright
  • Fade Dark
  • Fade Gray
  • Fade White
  • Warp Fade
  • Wave Dissolve

Movements

  • Flip
  • Fly In
  • Iris
  • Mosaic
  • Move In
  • Push
  • Ripple
  • Swap

None

  • Cut

Objects

  • Cross Hatch
  • Cube
  • Door
  • Kaleidoscope Wipe
  • Random Pixels
  • Random Squares
  • Random Squares Flicker

Random (Windows Only)

  • Mod

Wipes

  • Amoeba
  • Reveal
  • Square Wipe
  • Wipe